Support » Plugin: Postie » Re-Publish an EMail

  • Resolved joshuabaer23


    I notice while troubleshooting, that once an email has been read and archived, that I can not pull that email out of my email trash, then re-run Postie to re-publish the post.

    Scenario, in case Im not clear:
    This week something went wrong and about a dozen posts came out blank from Postie. No idea why that occurred, but as I went to rectify it, I simply marked the problem emails unread and put them back to the proper inbox. I then re-run postie expecting to see those emails turned to posts. Nothing at all occurs. I have tested this matter many times over the last few years with the same result. SOmetimes I can delete the original post created by postie and it will work after re-running the process, but normally it does nothing.

    Im not sure if that behavior is expected or not.
    Do you have suggestions for re-running problem email/posts? All I can do at this time is re-send the email, which in my case has been rather time consuming since they come from an automated crm.

    I should note that I use Postie Shortcodes and Im pretty sure I am up to date using Postie 1.9.13 and Shortcodes 1.2.7

    So any ideas on the above? If this is expected behavior for a reason I didnt consider, do you plan to add features to re-run problem actions like my scenario? Sometimes I have to re-do 50 or more posts and if there was an improved method, Id surely pay for it.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter joshuabaer23


    I am attaching my debug. This is while I have 10 emails in the proper inbox. These ten emails were already “postied” last week, but they didnt become a pst as I needed them. Note, I am removing the email address used from debug

    postiePostie Settings (v1.9.13)
    Starting mail fetch
    WordPress datetime: 2017-11-27 17:22:12
    doing postie_session_start
    OS: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u5 (2017-09-19) x86_64
    PHP Version: 5.6.30-0+deb8u1
    PHP error_log:
    PHP log_errors: On
    PHP get_temp_dir: /tmp/
    PHP cURL version: 7.38.0
    MySQL Version: 5.6.37
    WordPress Version: 4.9
    WordPress Singlesite
    WP_TEMP_DIR: (none)
    WP_HOME: (none)
    WP_SITEURL: (none)
    WP_DEBUG: Off
    WP_MAX_MEMORY_LIMIT: 256M (default)
    iconv: present
    Active plugins
    [0] => advanced-custom-fields/acf.php
    [1] => autodescription/autodescription.php
    [2] => automatic-dns-prefetch/automatic-dns-prefetch.php
    [3] => automatic-post-date-filler/automatic-post-date-filler.php
    [4] => codepeople-post-map/codepeople-post-map.php
    [5] => custom-admin-style/custom-admin-style.php
    [6] => fusion-builder/fusion-builder.php
    [7] => fusion-core/fusion-core.php
    [8] => insert-pages/insert-pages.php
    [9] => postie-shortcodes/postie-shortcodes.php
    [10] => postie/postie.php
    [11] => redirection/redirection.php
    [12] => resize-image-after-upload/resize-image-after-upload.php
    [13] => revslider/revslider.php
    [14] => scheduled-post-trigger/scheduled-post-trigger.php
    [15] => the-events-calendar/the-events-calendar.php
    [16] => w3-total-cache/w3-total-cache.php
    Postie is in /home/
    Postie Version: 1.9.13
    wp_content_path: /home/
    memory at start of email processing: 23899200
    getemails: Connecting to (pop3-ssl)
    getemails: procol: pop3-ssl
    pConnection: mailbox: INBOX
    Connecting via Socket
    Socket: tls://
    Socket error: 0 –
    Socket: POP3
    socket read (1) :+OK Gpop ready for requests from u124mb86016525ywe
    Socket: attempting a secure connection
    socket write: STLS
    socket read (1) :-ERR not supported u124mb86016525ywe
    socket write: USER
    socket read (1) :+OK send PASS
    socket write: (login) LOGIN/APOP/PASS
    socket read (1) :+OK Welcome.
    getemails: listing messages

    Plugin Author Wayne Allen


    This may be something to do with Gmail POP. I reprocess emails in the way you describe all the time, however, I am access Gmail via IMAP. Try switching.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Re-Publish an EMail’ is closed to new replies.