Support » Plugin: ALO EasyMail Newsletter » Re-Permission Campaign – Confirmation seems not to work

  • Uobet

    (@uobet)



    I would like to send off a re-permission campaign and tried it with a test newsletter and some test email adresses.

    I created a test newsletter (including the option re-permission campaign) and the shortcut [CONFIRMATION-LINK].

    I noted that as soon as the mail ist sent off the subscriber status changes to deactivated (int the my-sql table easymail_subscribers, field “active” the value changes vom 1 to 0).

    Then I tried to open the newsletter-mail and to click on the respective link (confirmation-link). I tried:
    a) to just go to the subscription page and not do do anything (as there the “Yes I would like…” option was already flagged;
    b) as step a) but additionally to select first the option no and afterwards yes.

    But neither step a) nor b) seems to work, the recepients status remains 0.

    What could I do to make it work? Ideal would be, if already option a) worked as I can’t expect useres to change first no and aferwards yes (mostl likely lots of subscribers would not do it, forget it or not understand it).

    Thank you

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author eventualo

    (@eventualo)

    Hi Uobet, it’s right that a subscriber is deactivated when his/her re-permission message goes out.
    About the confirmation link, maybe you clicked it on a browser where you was logged in. You should follow the confirmation link on a new browser window (to be sure you can use incognito/private window).
    The confirmation link should work for real subscribers, they follow the link and update own status to active. Please make a test and let us know.

    Uobet

    (@uobet)

    Hi Eventualo,

    thank you for your answer, I tried again (now from another browser), but I did not succeed.
    I carried out the following steps (in detail):
    – First I deleted the existing test subscribers, checking also the my-sql-tables;
    – Then I opened the subscribers again (three emails, no wordpress users);
    – I checked the table easymail subscribers; they where there, their status in the field “active” was “1”;
    – Then I sent off a test newsletter to all of them (re-permission campaig flagged);
    – I checked the table easymail_subscribers again: the status in the field “active” now changed to 0;
    – I opened another browser and opened the first E-Mail-account;
    – I clicked on the link created by the shortcut [USER-UNSUBSCRIBE]…I was forwarded to the respective link of WordPress. This time there weren’t any fields flagged. In my last test this was the case (you were right, this happened because I opened it from a browser where I was logged in in wordpress at the same time). So far everything ok;
    – I closed the browser, reopened it and logged in to another email account. This time I clicked on the respective link of the shortcut [CONFIRMATION-LINK]. I was again forwarded to the respective wordpress subscription page (the fields were again empty). This time wordpress gave me a message that the email had already been registered and that I had to feed in the fields and confirm. So far ok, I did it. Afterwards I got the msg. that a confirmation link had ben sent to mail email box.
    – I opened the email box again, opened the respective mail and confirmed the subscription….and fromw now on the plugin is behaving strangely…it forwarded me again to the subscription page in wordpress (which was again empty, with the msg that the email adress was already existing but not acitivated….and it started a kind of “endless loop” with no way out…
    I also checked the mysql table, the field active remained “0”.

    Can you think of a solution which could solve my problem?

    Thank you

    Plugin Author eventualo

    (@eventualo)

    Hi uobet, thanks a lot for your report.
    Sorry but I cannot reproduce this error now. I’ll investigate more as soon as possible with more accurate tests.
    If you like, you can make another test opening the emails on different devices (e.g. the 1st on your desktop, the 2nd on your smartphone) to be sure to have new clean session for each subscriber.

    Uobet

    (@uobet)

    Hi eventualo,

    I made another test with my pc and my two smartphones. Unfortunately the plugin behaves exactly the same.

    I hope it will be possible to solve the problem.

    [ Please do not bump. ]

    Unfortunately I have the same issue.

    I tested and double-tested the Re-Permission Campaign several times, but now when I have sent out the actual newsletter to 3k subscribers, the activation link does not work.

    Luckily I saw the error and was able to pause the newsletter when only 25 was sent out (to the few blog subscribers I have, I don’t really use that feature).

    From my tests, I saw the (working) confirmation link looking like https://mydomain.com/?lang=da&emact=amFjb2JAbW9yZXRvY29tZS5ka3w5OGM4ODA1MzVkYTI0OTg3YmQxMjNhZmZ8ZGF8

    But in the email from the “live” newsletter I just received, the link seems to be truncated, like: https://mydomain.com/?lang=da&emact=fHxkYXw%3D
    and the link does not do anything, it just leads to a blank page.

    Notice the escaped = sign in the end. Could it be, that some character is not escaped properly?

    • This reply was modified 7 months, 3 weeks ago by  papagoejoe.
    Plugin Author eventualo

    (@eventualo)

    Hi papagoejoe, thanks for the report.
    You can make a test using debug feature (set it in Newsletters > Settings > tab Newsletter) to print all emails inside a log file: please look inside this log file and check if the confirmation links are correct or trunked.
    In next days I’ll investigate about it too.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Re-Permission Campaign – Confirmation seems not to work’ is closed to new replies.