Support » Installing WordPress » Re-install

  • I thought I’d better register. All these Anonymous posts are a bit difficult to follow. 😉
    My last install didn’t quite work out so I decided to re-install but was told ‘you already have a wordpress database, dumbo’ or something like that, so I deleted the database. Now, every time I try to install, I get the same fault. Any suggestions?
    This is the response I get when I attempt to install (to my server on my own machine)…
    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.”); require_once(‘../wp-config.php’); require(‘upgrade-functions.php’); if (isset($_GET[‘step’])) $step = $_GET[‘step’]; else $step = 0; ?>
    hide_errors(); $installed = $wpdb->get_results(“SELECT * FROM $tableusers”); if ($installed) die(__(‘
    You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.
    ‘)); $wpdb->show_errors(); switch($step) { case 0: ?>
    Welcome to WordPress. We�re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. Before we get started, remember that we require a PHP version of at least 4.1.0, you have . Look good? You also need to set up the database connection information in wp-config.php. Have you looked at the readme? If you�re all ready, let’s go!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Mark (podz)

    (@podz)

    Support Maven

    You need to clear (drop) the database tables.
    http://www.tamba2.org.uk/wordpress/empty-drop/

    That’s done, plus I’ve been through the registry and taken out everything that has the word ‘wordpress’ in it and I’m still getting the same error. Any other ideas?

    Mark (podz)

    (@podz)

    Support Maven

    What setup do you have ?
    The registry does not get involved with wp.
    Open ‘wp-config.php’, and find the ‘table_prefix’.
    It will probably be ‘wp_’
    Change that to ‘wp1_’ and try the install.

    Ah – might be getting somewhere here. Whatever I type into that part of wp-config.php, or whatever name I give the new database, the response is always ‘You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.’
    In an attempt to get through this, I even named it ‘ketlan’ and still got the same response.
    Obviously something’s wrong but I’m buggered if I can see what.
    Oh, and the db ‘ketlan’ did not get created. I’m completely at a loss here (though, much against my better nature, I’m starting to get the hang of php files)…

    This is madness. I can feel my braincells dissolving by the billion…
    I just ran upgrade.php. It seemed to work fine until I attempted to go to index.php, then I got this message:
    ‘We’re having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as wordpress. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?’
    I return to install.php and get the same message I had originally (in the first post of this thread). Either the database exists or it doesn’t!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Re-install’ is closed to new replies.