Support » Plugin: SmartCrawl SEO » Re: Category Page Title and redundant Canonicals

  • Resolved swagatam1975

    (@swagatam1975)


    Hello Team WPMU,

    Thank you for this amazing SEO plugin!

    Everything is great except the following two minor doubts, I hope you will be able to clarify them:

    1) I have set my category to noindex, however the Page titles for each of these categories show %%page%% after the actual Name. For example, the category “Audio Projects” appear as “Audio Projects %%page%%” on the browser tab, and also on the page source under <title>

    2) When I conduct an SEO Checkup, it gives a warning under the canonical box, which says:

    “The canonical link tag is being used on your site. Having said that, the preferred URL for search results points to (My Domain Name with https and www), which seems to be redundant.”

    I’d be grateful and appreciate it a lot if you could solve these issues.

    Thank you Very Much in Advance!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello there @swagatam1975

    1)
    Disabling indexing means that this content will not be indexed and searchable in search engines. This won’t change the actual titles though.
    Could you please try to edit Categories titles to the default value:
    %%category%% %%sep%% %%sitename%%
    screenshot: https://monosnap.com/file/EvYKnXEkEqlsdHd3uYoJ4hw8IDmoxC

    Please keep in mind that %%page%% macro won’t be able to render anything, as all categories’ pages are virtual pages, not normal Pages that you can manually create.

    2)
    This is about this meta tag:
    https://monosnap.com/file/xIOoMxCiFQGtIoklYtQU3RgZeF7D6b
    More info: https://moz.com/learn/seo/canonicalization

    You can remove this by going to SmartCrawl -> Settings -> General Settings -> Meta tags -> Hide Redundant Canonical Link Tags
    https://monosnap.com/file/ZqQxoachNlYRo93bPfvM3cbkOcxwtC

    Warm regards,
    Dimitris

    swagatam1975

    (@swagatam1975)

    Thank you very much for the reply,

    I have implemented the suggestions, the first issue is solved, the %%page%% macro don’t appear anymore, however the second issue is still not corrected.

    I have toggled the “Hide Redundant Canonical Link Tags”, but the SEO checkup keeps showing me the warning regarding redundant canonicals. Also I could not understand what exactly is causing this redundancy issue, is it because the canonicals are appearing more than once?

    Please help me to solve the above issue! It’ll be greatly appreciated!

    Best Regards

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @swagatam1975

    I gave this another try in another testing installation and after enabling the “Hide Redundant Canonical Link Tags” and running a new “SEO Checkup”, I no longer getting the error about the redundant link in homepage but a more generic message:

    Recommendation
    Duplicate content spread across multiple URLs can have a negative impact on your page rank. Using a canonical URL for products or content that is accessible under multiple URLs or websites can allow them to exist without harming your rankings.

    Did you re-run the SEO Checkup after making changes in settings?
    Are you getting this message now instead? If so, then it’s good to ignore it.

    The redundancy is because homepage is having a canonical URL which links into the same homepage URL. It’s not something bad, just redundant, so even if you disable the setting about Redundant Canonical Link Tags it’s something that you can ignore, as it won’t cause any actual SEO issues. 🙂

    Warm regards,
    Dimitris

    Thank you so much Dimitris,

    I appreciate your kind support very much!

    Yes I re-ran the Seo checkup and it continued showing the same redundancy message. Actually the Seo checkup feature allows only one checkup every 24 hours, therefore I am unable to reconfirm this until tomorrow 11 am (Indian Time Zone).

    OK, if you are saying that even with this existing warning there’s no need to worry, then can I revert the setting to the previous condition? That is, can I again disable “Hide Redundant Canonical Tag” button to its original condition?

    Kindly advise!

    Thanks very much in advance!

    Best Regards
    Swagatam

    • This reply was modified 5 months, 4 weeks ago by  swagatam1975.

    OK, I ran the Seo checkup again today but the canonical warning message remained unchanged.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.