Support » Plugin: Defender Security - Malware Scanner, Login Security & Firewall » Rate Plugin constantly appearing

  • Resolved poescp

    (@poescp)


    The free Defender Plugin keeps showing Rate Defender or Maybe Later.
    No matter what I press the notification keeps occuring. It has nothing to do with the Server Cache and local WP cache in my case.
    Is there any PHP script I can add so it is not shown or solve it in any way.
    My setup:
    Antispam Bee
    Avada Builder
    Avada Core
    Borlabs Cookie – Cookie Opt-in
    Buchungskalender
    Checkout Field Editor for WooCommerce
    Contact Form 7
    Defender
    eRecht24 Safe Sharing
    Germanized für WooCommerce
    Heartbeat Control by WP Rocket
    Honeypot for Contact Form 7
    Loco Translate
    MC4WP: Mailchimp for WordPress
    My Custom Functions
    Smush
    Social Slider Widget
    Social Slider Widget premium Premium
    Woo Donations
    WooCommerce
    WooCommerce PDF Invoices & Packing Slips
    WooCommerce Serial Numbers
    WooCommerce Serial Numbers Pro
    WooCommerce Stripe-Gateway
    WP 404 Auto Redirect to Similar Post
    WP Fastest Cache
    WP Fastest Cache Premium
    WP Mail SMTP
    Yoast SEO

    Wordpress newest todays version

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @poescp,

    Just to be sure, you meant even after dismissing the notification, it occurs on the next page refresh? or do you notice it after a while?

    Could we also know it’s specific to any pages in Defender you notice this behaviour or is it the same with all pages?

    In general, we have noticed such cases to occur due to Object cache, I see you have mentioned server cache, but still double-checking whether you have ruled out Object Cache or not?

    Please do confirm so that we could check further if needed. Looking forward to your response.

    Kind Regards,
    Nithin

    Thread Starter poescp

    (@poescp)

    I notice it straight away, after change to each page. With all pages.
    I use multisite WP by the way if that may be of importance.
    Object cache is delted, no cache on the Server. I double checked it.

    Is there no php I can add to have the notice go away? Or other solution?

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @poescp,

    It seems that Defender is unable to update the DB status for the notice and it keeps showing it because of that.
    Could you try following the below steps to mark it as read directly in DB and that should do the trick:
    – Create a backup of your DB, just in case, it’s always best to be safe when making changes in DB
    – Open wp_options table (wp_ prefix can be different on your installation)
    – Find defender_days_rating_later_dismiss option_name inside wp_options table
    – The value for that option would probably be 0 for you, change it to 1 and that should be it.

    Let us know if this helped.

    Cheers,
    Predrag

    Thread Starter poescp

    (@poescp)

    Was already set to 1.
    I changed it to 0 and then back to 1, but that did not solve it either.

    Installed a WP plugin delete OPCache, cleared OPCache, but still problem of showing constantly up.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @poescp

    Thanks for response!

    If this value is set to 1 it means that notification is disabled. If Defender is still displaying it “no matter what” it means that either the page content is cached (but you mentioned multiple times that all caches have been cleared and also, usually, wp-admin pages are not cached that way) or that it’s not getting correct data from the database.

    That latter actually brings me back to… cache. My colleague earlier mentioned Object Cache. You have mentioned clearing OPCache but OPCache and Object Cache are not the same – they are different things.

    Object Cache is (often quite persistent) DB-related cache. It’s caching responses to recent/most used DB queries so if such response is cached, whenever DB is queried, the response is returned from that cache. It’s very common that such cache affects (various) site setting in similar way – because plugin/script actually doesn’t see a real/recent value form the DB.

    Note also: deleting Object Cache doesn’t mean deleting an “object-cache.php” file from /wp-content folder. On the contrary – deleting it, if there is object cache implemented on server – can in fact make things worse.

    That said, I would strongly recommend contacting your host again and asking them specifically about Object Cache (not OPCache!) and if it could be cleared again. After that also again clear all other caches, including CDN such as e.g. CloudFlare (if you are using it).

    It it still doesn’t help, please try re-installing Defender:
    – in Defender settings set it to delete configuration and data (you’ll have to configure it form scratch after re-installation but otherwise it won’t change anything)
    – then disable and delete plugin via “Plugins” page
    – then again clear all possible caches on site and server
    – then re-install Defender.

    If that still doesn’t work, let us know please.

    Kind regards,
    Adam

    Thread Starter poescp

    (@poescp)

    All done, no solution, still appears. Object Cache – not solved with this solution, re-install, after delete of preferences acc. to your description above etc.
    Perhaps to do with Multisite?

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @poescp

    To confirm it isn’t a plugin conflict, can you create a staging website following this guide https://wpmudev.com/blog/set-up-staging-site-cheap-shared-hosting/ or using the WP Staging plugin and then follow the full plugin conflict test workflow:

    https://wpmudev.com/wp-content/uploads/2015/09/Support-Process-Support-Process.gif

    Let us know the result you got.
    Best Regards
    Patrick Freitas

    Thread Starter poescp

    (@poescp)

    Tried this, did not solve the problem. Deactivated all plugins, excep defender and issue still persists.

    Is there no php code or so or hardcoding possibility for me so I can change this notification. Which file would I need to change? I am able to do this.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @poescp

    There’s not really much that could be done without directly editing plugin’s code and this is something never recommended so I’d prefer to go for it only if absolutely nothing else works.

    I got a feeling that we are all still missing something here and it’s quite likely something pretty simple but apart from this, there’s one more thing worth trying on DB level (I just tested it on my setup and it did the trick) – you would need to “inject” new option to the dB most likely.

    Here’s what would have to be done:

    1. in wp_options table look for the option_name defender_rating_success

    2. if it’s there, it most likely have option_value of 0 so change it to 1

    3. if it’s not there, add such option – simply click on “Insert” in phpMyAdmin while you’re in the wp_options table and put defender_rating_success in “option_name” field and 1 in “option_value” field and then click “Go” to add it to DB.

    Once it’s confirmed that it’s added, again clear all possible caches and check the site, I think the notification should be gone now.

    Best regards,
    Adam

    Thread Starter poescp

    (@poescp)

    Still no solution defender_days_rating_later_dismiss and defender_rating_success are both already on 1 for all three multisites.
    fwaploptions
    fwapl3_options
    fwapl2_options

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @poescp,

    Are all 3 networks hosted with same hosting provider?
    If that’s the case, can you tell us name of your hosting provider?

    Cheers,
    Predrag

    Thread Starter poescp

    (@poescp)

    I host them on my own dedicated server.

    Plugin Support Nebu John – WPMU DEV Support

    (@wpmudevsupport14)

    Hi @poescp,

    We have brought this to the notice of the Defender developers and shall get back to you here once we have feedback on this as soon as possible. We really appreciate your patience on this.

    Kind Regards,
    Nebu John

    Plugin Support Nebu John – WPMU DEV Support

    (@wpmudevsupport14)

    Hi again,

    Can you please also let us know one of the site URL that you notice this issue with? If you are not comfortable with sharing the URL here, can you please use our secure contact form instead?

    Please send us the details using our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: “Attn: Nebu John”
    
     – Site URL
     – Link back to this thread for reference

    Looking forward to hearing back from you.

    Kind Regards,
    Nebu John

    Thread Starter poescp

    (@poescp)

    sent it to you

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Rate Plugin constantly appearing’ is closed to new replies.