Support » Plugin: Wordfence Security - Firewall & Malware Scan » Rate limiting blocking people it shouldn’t.

  • Resolved Starhorsepax2

    (@starhorsepax2)


    Now I do have rate limiting SET. But it is set at 30. Yet now users I send to are clicking ONCE on a link that I send of a page that DOES exist and getting this message. They only tried to access ONCE.

    “Your access to this site has been limited

    Your access to this service has been temporarily limited. Please try again in a few minutes. (HTTP response code 503)

    Reason: Exceeded the maximum number of page not found errors per minute for humans.”

    Why is it doing this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support wfdave

    (@wfdave)

    Hi @starhorsepax2,

    Can you try this?

    1. Open a new tab
    2. Press F12 to open the developer’s console
    3. Go to the Network tab
    4. Load your site in the new tab (load the link you are sending to your users)

    For example: https://i.imgur.com/eJvLtG3.png

    Check to see if there are any 404 errors (or any other errors highlighted with red).

    I suspect that the page you are linking off to has a lot of references to 404 images, and that is what is triggering the maximum number of page not found errors so rapidly.

    Dave

    The link is straight to the login page. There are no images.

    Plugin Support wfdave

    (@wfdave)

    Hi again,

    It may not be images, but different assets that are returning a 404 code.

    Can you take a screenshot of what you saw when you opened the developer’s console -> Network tab?

    It’s possible that the IP detection method used on your site is misconfigured. Can you take a look at Wordfence -> All Options -> How does Wordfence get its IPs?

    What is set for that value, and does it match the IP found here? https://www.google.com/search?q=what+is+my+ip

    Dave

    Hi I’m still getting this. It is blocking the admins. It is blocking ME. I am not hitting even ONE 404 in the process but it claims I’ve hit the limit.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.