Support » Plugin: Rotating Tweets (Twitter widget and shortcode) » Rate Limit Exceeded…error 88

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Martin Tod

    (@mpntod)

    That’s odd. Although the tweets should still be showing even if there is rate-limiting. Can you send me a link?

    How many different widgets or shortcodes are you using? Are you calling a lot of ‘favorites’? Most Twitter accounts are allowed 180 calls every 15 minutes (apart from for calls for favorites) – which should be plenty – since FT only calls Twitter once every 2 minutes. More details of how many ‘calls’ are allowed every 15 minutes at https://dev.twitter.com/docs/rate-limiting/1.1/limits .

    The immediate fix is to make cacheing last longer – by changing line 791 from:

    $cache_delay = 120;

    to

    $cache_delay = 240;

    Martin

    I need to only call favorites. Will changing the cache delay fix that? We get over 1K visitors a day.

    Plugin Author Martin Tod

    (@mpntod)

    Changing the cache will definitely help.

    How many favourites are you calling?

    The limit for calling GET favourites/list is 15 calls every 15 minutes per Twitter account.

    So if you’re calling more than one favourite, or using the same Twitter credentials to call for favourites on more than one website, you’ll hit rate-limits.

    Realistically, people don’t generally add favourites particularly often, so you could make doubly sure to avoid rate-limiting, by setting the cache time to an hour (3600) or longer.

    I’ll add the option to the development version of the plug-in – but you will need to edit the code short-term.

    Martin

    I don’t need it to pull in live…it is being used to show reviews of our company from people on Twitter (that we’ve saved as favorites). I set it to 24 hours. We will see how that works! http://www.darquetan.com

    Plugin Author Martin Tod

    (@mpntod)

    Seems to be OK currently!

    Let me know if there is a problem.

    Martin

    Actually that never worked using favorites. I ended up having to make a separate twitter that then just RT’d everything I wanted to show on my page. Favorites are too restricted. Not sure why the cache didn’t work. I even set it to 24 hrs. and it was still having issues. Luckily I found a workaround that worked for me. Thanks Martin! Love that you’re on top of this stuff :-). Love rotatingtweets as well 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Rate Limit Exceeded…error 88’ is closed to new replies.