Support » Localhost Installs » RaspberryPi PressPi won’t Update

  • Hello WordPress!
    I have been running WordPress using the PressPi image on my raspberry pi for about a year and it has worked great until now. When I try to auto update wordpress, I get the following message:

    Downloading update from https://downloads.wordpress.org/release/wordpress-4.9.1-no-content.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Preparing to install the latest version…

    The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.: wp-includes/functions.php

    Installation Failed
    ——
    I do not know what was different this time on this update. I tried rolling back all of my plugins with no luck.
    What should I do to gain consistent file permissions?

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Neil

    (@neilgilmour)

    WCLDN 2018 Contributor

    Hi there,

    After a quick search, these posts came up which might help you.

    https://aaronjholbrook.com/wordpress-permissions-update-error-resolved/
    https://wordpress.org/support/topic/inconsistent-file-permission-error-when-attempting-to-update-wordpress/

    However, their error messages mention a different file to you. So I’m wondering if you’ve made any changes to functions.php, and if so how did you do it? I would check what permission is on functions.php. I’m guessing that if you’re using a pi you won’t need it, but here’s a refresher on file permissions in WordPress: https://codex.wordpress.org/Changing_File_Permissions

    A recurrent problem with localhost installs is that due to file and directory permission issues, that auto updates / media uploads / plugin and theme installs all fail. The commonest outcome is that rather than fixing the issue, it is easier to do any of the updates manually using manual file copy tools. This need not be a problem.

    Thank you Neil and RossMitchell for your responses.

    @rossmitchell – I will definitely keep the manual update method in mind if needed.
    @neil – Thank you for your fast response and specific links. I did see those links before posting here and I see what you mean they referenced a different problem file than my error message. I have solved the issue, but it is a little bit of a strange situation how I did it.

    I am using the PressPi raspberryPi image to run my wordpress site. I am not too experienced with command lines in the Pi, but have managed what I needed up to now.
    My WordPress files, such as files in wp-includes, are easily visible in windows file explorer on ‘network’, but I could never find them using FTP program such as FileZilla.

    The fix came from right clicking on the functions.php file and changing the permissions to get auto update in WordPress to run.

    The fix came from right clicking on the functions.php file and changing the permissions to get auto update in WordPress to run.

    Please, please, what did you change the permissions (+ownership?) from to, providing details like this are IMHO how the community and volunteers get their rewards.

    I should have been more detailed before, someone else could benefit from it!

    I viewed my ‘PRESSPI’ RaspberryPi machine under ‘Network’ in Windows explorer – navigated to WordPress/wp-includes/functions.php
    – right clicked functions.php file
    – selected ‘properties’
    – selected ‘security’ tab
    – In ‘Group or user names’ box I selected ‘Everyone’ then clicked the Edit button
    – Then selected check marks next to:
    — Read & Execute
    — Read
    — Write
    — Special permissions
    (I did this process in the Edit box again for the ‘Group or user name’ called root(Unix Group\root) as well. The one called root(Unix User\root) already had all the same boxes checked.)

    – Clicked Apply and ‘OKed’ through the two windows.

    After that, I went to my WordPress dashboard in my web browser and was able to update my WordPress to 4.9.1 through the dashboard 🙂 🙂

    ——–
    An interesting note to the permissions granted in windows explorer..When I went through this process again just now after having completed the WordPress update as mentioned above, the extra permissions I had check marked for ‘Everyone’ and ‘root(Unix Group\root)’ are now unchecked. Only root(Unix User\root) has all of the read/execute, write, special permissions boxes checked still.
    ——–

    • This reply was modified 2 years, 3 months ago by inventor84.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘RaspberryPi PressPi won’t Update’ is closed to new replies.