Support » Plugin: Foyer - Digital Signage for WordPress » Raspberry Pi 4B and Videos with Foyer: Some Success

  • Hi all,

    I’m using Foyer as part of a university project, using a Pi and Open Source software to build an eco friendly Digital Signage solution.

    I’ve seen some having issues getting videos working on the Pi, and user @bangel had some success. Since no one gave a full answer, I thought I’d share my findings.

    I’m using a 4B 4GB model, with Pi OS, WP 5.8.1 and Foyer 1.7.5.

    For me, I upped my GPU RAM to 512mb, and chrome://flags changed
    GPU Rasterization – Enabled
    Override software rendering list – Enabled

    Hardware Video Decoding remains unavailable for me, some people on the net have it working and think it might be key.

    This allows some 10mb files (buck bunny clips) to play and for YouTube to load, BUT it needs the user to click somewhere on the browser, otherwise it will just show the first frame of the video, stay for the default slide duration and move to the next.

    Firefox plays *some* vids without intervention, YouTube has no sound.

    Edit: adding the following to your chromium command fixes the click-to-play issue
    –autoplay-policy=no-user-gesture-required

    • This topic was modified 1 year, 1 month ago by dwodge77.
    • This topic was modified 1 year, 1 month ago by dwodge77. Reason: Versions and spelling
    • This topic was modified 1 year, 1 month ago by dwodge77. Reason: Update to problem
    • This topic was modified 1 year, 1 month ago by dwodge77. Reason: Spelling
  • The topic ‘Raspberry Pi 4B and Videos with Foyer: Some Success’ is closed to new replies.