Support » Plugin: FooGallery - Image Gallery WordPress Plugin » Randomly get outlines but no images

  • Resolved dogrescuer

    (@dogrescuer)


    http://prntscr.com/m14q8c

    Hello, we are getting a series of lines without images on multiple instances of the gallery throughout the site. Console is not giving errors. More often than not the gallery will load upon control f5. Debugging per plugin is iffy because the issues doesn’t always show, so it might work because I turned off a plugin or because it just decided to work this time. Thanks for any insight.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author bradvin

    (@bradvin)

    I had a look at your page and the gallery loaded fine. What version of FooGallery are you running?

    I also noticed you are running Autoptimize. Can you try deactivating autoptomize to see if you still have the issue?

    pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there are troubleshooting tips and info on how to exclude in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    I believe you’ve pegged it. It appears to be the Optimize HTML checkbox in Autoptimize.

    weird, as optimize HTML is not invasive. on the other hand it is not the most important optimization either, so … 🙂

    agreed, I thought it would have been one of the others. Could be a false positive, I’ll report back if I figure it out.

    dogrescuer

    (@dogrescuer)

    Hello. It’s not autoptimize. That’s off and I still have the symptom

    dogrescuer

    (@dogrescuer)

    @bradvin my money is currently on the Smush plugin causing the Foo gallery not to load.

    Plugin Support phillcoxon

    (@phillcoxon)

    @dogrescuer – have you also tried disabling Smush and re-testing.

    Just a thought with Autoptimize – when you deactivated it did you clear any caches and test from a Private Browser / Incognito browser to eliminate any caching left in the browser?

    dogrescuer

    (@dogrescuer)

    I get proper Foo display when I turn off W3 Total Cache and WP Smush. Both are interfering with Foo displaying.

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @dogrescuer,

    Thanks for the reply.

    The best thing to do is work through the W3 Total Cache settings and adjust the javascript minimization settings so they are compatible with FooGallery.

    Caching / javascript minimisation / optimization plugins can sometimes cause other plugins to break if they do things like try to further minimize javascript files that have already been minimized. Adjusting the settings to reduce how much minimization is done or to specifically exclude scripts that break with further minimization can resolve the issue.

    Off the top of my head I’m not sure why WP Smush would be interfering with FooGallery – it would be worth checking the WP Smush settings to see fi there is anything that can be tweaked or perhaps try an alternative such as ShortPixel image optimizer.

    Good luck with tweaking your settings and please feel free to reach out again if we can help with anything else.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.