Support » Plugin: WooCommerce » random woo stuff appearing as comments on my blog posts

  • Resolved kipwinsett

    (@kipwinsett)


    I recently installed Woo Commerce on my site winsamor.com I ran a speed test on the site and it was very slow, so I deactivated Woo commerce all plugins to see if Woo was the problems. It wasn’t but I haven’t yet reactivated Woo. Today I noticed that all of my blog posts now have random Woo stuff as comments.
    ActionScheduler on woocommerce_update_marketplace_suggestions
    ActionScheduler on woocommerce_update_marketplace_suggestions
    ActionScheduler on woocommerce_update_marketplace_suggestions

    Here is a blog post so you can see what I mean. https://www.winsamor.com/2019/05/27/helping-you-find-the-right-diaper-bag-by-use-style-size-price/

    Obviously I don’t want that kind of junk on my site but I didn’t know how to get rid of it.

    I had just installed woo on a second site that isn’t yet published so I deactivated all of the components on there and had the same problem. Then I reactivated the components 1 by 1 and looked at a post after each reactivation. It turns out that when the main component (WooCommerce) is deactivated that random stuff appears in the top 3 recent comments section. If it is active the random clutter disappears.

    So apparently WOO doesn’t want to let me deactivate. OK, I could keep it active and not publish a shopping page, but Woo puts a shopping cart as a dead link in my navigation menu. I don’t want that there if it doesn’t work.

    BTW When I tried to activate the deactivated “Pay by Paypal Checkout Gateway” component I got this error

    Fatal error: Uncaught Error: Call to undefined function get_woocommerce_currency() in /home3/hdsproco/public_html/diaperbagbackpack/wp-content/plugins/woocommerce-gateway-paypal-express-checkout/includes/class-wc-gateway-ppec-settings.php:293 Stack trace: #0 /home3/hdsproco/public_html/diaperbagbackpack/wp-content/plugins/woocommerce-gateway-paypal-express-checkout/includes/class-wc-gateway-ppec-plugin.php(354): WC_Gateway_PPEC_Settings->currency_has_decimal_restriction() #1 /home3/hdsproco/public_html/diaperbagbackpack/wp-includes/class-wp-hook.php(286): WC_Gateway_PPEC_Plugin->activate(”) #2 /home3/hdsproco/public_html/diaperbagbackpack/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #3 /home3/hdsproco/public_html/diaperbagbackpack/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #4 /home3/hdsproco/public_html/diaperbagbackpack/wp-admin/plugins.php(177): do_action(‘activate_woocom…’) #5 {main} thrown in /home3/hdsproco/public_html/diaperbagbackpack/wp-content/plugins/woocommerce-gateway-paypal-express-checkout/includes/class-wc-gateway-ppec-settings.php on line 293

    So I have no idea what to do about either of these problems. Anyone know anything about this?

    I thought Woo was a stable platform.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Have you turned off marketplace suggestions at:
    Dashboard > WooCommerce > Settings > Advanced tab, “Show suggestions” checkbox.

    It won’t get rid of suggestions that have already been made. They will have to be deleted manually.

    The error message is coming from a plugin called: “woocommerce-gateway-paypal-express”, not from the WooCommerce plugin. woocommerce-gateway-paypal-express is a premium plugin from woocommerce.com. If you have purchased it, you will be able to get support for it through woocommerce.com, not here.

    If you have not purchased it, you can use WooCommerce’s built-in PayPal gateway. Not as many features but it will be fine to start with, and maybe longer.

    Sometimes when people are new to WooCommerce, they make uninformed choices in the setup wizard because initially they don’t yet fully understand what is being offered. Its easy to accept defaults which link up your site to more services than you want just yet. The fix is to rerun the setup wizard:
    Dashboard > WooCommerce > Settings > Help (top right hand corner) > Setup Wizard

    You can run the wizard as many times as you need to, and be sure to understand the choices you are making.

    Plugin Support laceyrod a11n

    (@laceyrod)

    Automattic Happiness Engineer

    This thread has been inactive for a bit, so I’m going to mark it as Resolved now. Please feel free to open a new one if you have any further questions.

    Cheers!

    Thanks Lorro. That was useful advice for me.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘random woo stuff appearing as comments on my blog posts’ is closed to new replies.