Support » Plugin: Easy Testimonials » Random Testimonial Always Shoes The Same One

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have a feeling that you’re running into WP Engine’s caching layer. The static page cache should clear every 10 minutes. If you need to have a random testimonial every time someone visits the page, contact WP Engine support and ask them for a cache exception for that page. They’ll take care of you.

    Plugin Author richardgabriel

    (@richardgabriel)

    Hey Peter!

    To piggyback on boogah’s response, WP Engine also disables Random queries by default.

    If that is the case, you can find the option under your WP Engine Dashboard inside WordPress – there should be an option with wording about disabling Random SQL queries for performance reasons.

    If you disable that option, and verify any cache settings as Boogah suggests, then everything should function correctly.

    All the best,
    Richard

    Hi Richard

    Thanks very much that was it. I’ve enabled ‘Allow ORDER BY RAND()’ and it is now working perfectly when I’m logged into Admin.

    I knew it wasn’t caching causing the problem as that is disabled when logged in to Admin.

    Caching does cause a problem when not logged in but this isn’t too bad as different testimonials will be shown on different pages (previously it was the same one everywhere and every time).

    Once again, thank you very much.

    Kind regards…Peter

    Plugin Author richardgabriel

    (@richardgabriel)

    No problem, Peter, I’m glad I could help!

    Hi Boogah

    Thanks for your response. Although that wasn’t the root cause I didn’t realise (until I read your post) that the WPE cache clears every 10 minutes. In this case a refresh of the random testimonials every 10 minutes is absolutely fine.

    Kind regards…Peter

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Random Testimonial Always Shoes The Same One’ is closed to new replies.