Support » Plugin: LifterLMS » Random problem with membership and course access

  • Resolved Adam @ WPCrafter

    (@wpcrafter)


    I am having a weird issue. I have 9 courses which can be purchased individually. I also have a membership that includes all these courses.

    I do not have auto enroll enabled for the membership because not everyone is going to want to take all courses they have access to.

    Well for some of the the members of the membership, when they click on “Take This Course” they are not enrolled and are instead taken to a purchase page with my WooCommerce integration.

    I can duplicate the issue on my site.

    Any time or pointers?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Thomas Patrick Levy

    (@thomasplevy)

    @wpcrafter,

    Sounds like you’ve encountered a bug in our WC integration.

    The issue is that WC integration is not checking if the user is already enrolled in the associated membership

    I’d like to hold on this for the moment but the integration is completely rewritten for 3.0 and will resolve this issue due to fundamental changes in LLMS itself. If this is an emergency issue that you need a resolution for ASAP I can work on a patch but if you can live with it for a few more weeks until 3.0 is released I’d appreciate it. We are diverting almost all of our efforts to 3.0 testing in preparation for the release. It fixes so many issues I’ve lost count and this is just one of the many.

    Let me know how you’d like me to proceed,

    It’s fine for now, I can manage. Maybe i’ll pull 3.0 from github and test it one a dev instance.

    Thanks for the response.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Random problem with membership and course access’ is closed to new replies.