• Resolved Austin Ginder

    (@austinginder)


    I’ve been receiving the following notices from multiple websites running WordPress v5.2.1 and Easy Facebook Likebox v4.4.0. I’m not actually seeing any errors. It looks like this error is being trigger WP-CLI however I’m likewise not seeing any errors there either when I try. Looks like a coding issues which only fails under a specific circumstance.

    
    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.
    
    In this case, WordPress caught an error with one of your plugins, Easy Facebook Likebox.
    
    First, visit your website and check for any visible issues. Next, visit the page where the error was caught and check for any visible issues.
    
    Please contact your host for assistance with investigating this issue further.
    
    If your site appears broken and you can't access your dashboard normally, WordPress now has a special "recovery mode". This lets you safely login to your dashboard and investigate further.
    
    To keep your site safe, this link will expire in 1 day. Don't worry about that, though: a new link will be emailed to you if the error occurs again after it expires.
    
    Error Details
    =============
    An error of type E_ERROR was caused in line 63 of the file wp-content/plugins/easy-facebook-likebox/admin/easy-facebook-likebox-admin.php. Error message: Uncaught Error: Call to a member function get_plugin_slug() on null in wp-content/plugins/easy-facebook-likebox/admin/easy-facebook-likebox-admin.php:63
    Stack trace:
    #0 wp-content/plugins/easy-facebook-likebox/admin/easy-facebook-likebox-admin.php(106): Easy_Facebook_Likebox_Admin->__construct()
    #1 wp-includes/class-wp-hook.php(286): Easy_Facebook_Likebox_Admin::get_instance('')
    #2 wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(Object(Easy_Facebook_Likebox), Array)
    #3 wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    #4 wp-settings.php(394): do_action('plugins_loaded')
    #5 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1209): require('...')
    #6 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1130): WP_CLI\Runner->load_wordpress()
    #7 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Boo
    
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.