Support » Plugin: WP Job Manager » Random Order Issue

  • Resolved globerweb


    Hi! I use the Listable Theme and I used this article to get my listings to show in random order:
    However, when I implemented it, it showed randomly the first page, when I clicked “load more listings” it was showing some of the same listings from above, and so on…
    How can I get it to show unique listings without repetition when I click “load more”? Is there a code that I can implement which will:
    1. Show listings randomly without repeating them as user clicks “load more”
    2. Show Verified (incl. claimed) listings in random order first & then show Unverified/unclaimed listings second also in random order?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hey there,

    I’m Andrei, one of the Listable’s developer.

    I just tested your case on my local environment, and I cannot see any repeating listings after loading more listings.

    This may happen if the page where you have the orderby=”rand” attribute is not selected in Dashboard -> Listings -> Settings -> Pages at the Listing Listings Page option.

    About the second thing, with Claim listings, I think that requires a split query, and I don’t believe that there is an option for this. It can be done only with custom work.



    Thank you for the quick reply, Andrei!

    I posted the code as described in the article link I provided. I also contacted Listable support and they found the same issue. Here’s their reply:

    “You are right. That happens on a default theme as well, which means this is a core WP Job Manager problem. However, I can see there is no topic on their forum about it. Could you raise this problem on their forums perhaps?”

    Any chance we can chat offline and figure out what’s going on?

    Plugin Contributor jonryan


    @globerweb are you still having problems here?


    Yes, I had to remove that code because of the repeating listings after “load more”.

    Any help would be appreciated! Thanks

    Plugin Contributor jonryan


    @globerweb if you are still having this issue can you try deactivating all the non-WPJM plugins to see if this resolves the issue. If that doesn’t work try switching the theme using this plugin to see if this is a theme issue or not:

    Plugin Contributor Adam


    Resolving this as it’s been a month or more without a reply.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Random Order Issue’ is closed to new replies.