Support » Fixing WordPress » random </noscript> being added

  • At the end of posts that I make – especially ones where I edit my own HTML – a random line is added at the end:

    </noscript>

    This noscript causes the page to not have comments added to it, and basically no right nav or anything else on may page that comes after this line. And it only appears when I publish the blog, so then I have to go back in and remove it by hand for no good reason, but sometimes only after I realize a few hours later that it is there in the first place.

    Why is this code being added for me, and how do I stop it? It seems like a really annoying bug.

    Matt

Viewing 6 replies - 1 through 6 (of 6 total)
  • Do you use <noscript> anywhere on the page/post?

    I have never put it in myself. It is a tag I never use since I don’t find it too necessary to make the alternate versions for people not running javascript on their page. Maybe there is an open <noscript> tage somewhere in the rest of the code of the page, but that would be in the parts I didn’t write and don’t have control over… Which would make this a bug.

    Also, are you using the Rich Text Editor? That sometimes throws these errors, it’s wordpress’s achille’s heel!

    If you can bear to part with it, you can disable it and use the default editor which will let you edit all the HTML to your heart’s content.

    I’m not sure… There is a WYSIWYG editor that is there when I go to write a post – perhaps that is the rich text editor… how do I disable it?

    Yeah, the WYSIWYG thing is what I mean. In your profile, there should be a box near the bottom that talks about the “rich text editor” make sure it is cleared, and that should do the trick.

    You’ll get a plain text version where you can add tags that you want, but you don’t need to worry about line breaks and paragraphs since wordpress takes care of that for you!

    awesome, I have updated that, and I will see how it goes from here. Thanks for the help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘random </noscript> being added’ is closed to new replies.