Support » Plugin: Business Directory Plugin - Directories for WordPress » Random Listing Widget Error

  • Resolved sajay

    (@sajay)


    When I change the number of random listings in the widget to 1 I get the error

    Warning: Invalid argument supplied for foreach() in …plugins/business-directory-plugin/includes/widgets/widget-random-listings.php on line 32

    It only happens when the number of listings is set to 1.

Viewing 1 replies (of 1 total)
  • Plugin Author businessdirectoryplugin

    (@businessdirectoryplugin)

    Hi @sajay,

    Again, sorry that you ran into issues here!

    As I mentioned in the previous thread, it sounds like you’re upgrading from a very old version of BD. BD 5.5.x requires that you have PHP 5.6 or higher installed, and that error very much looks like you have something older than our minimum required version.

    Can you please confirm that under Directory Admin->Debug, Environment tab?

    If you have something earlier, please ask your web host to upgrade your server to PHP 5.6 or higher. We support anything from 5.6 to the latest PHP 7. WordPress also has this requirement as of WP 5.2, FYI.

    Try that and let me know if you run into more issues.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.