Support » Fixing WordPress » Random Hashtag Strings Added to URL in Firefox?

  • Resolved rmantenesse

    (@rmantenesse)


    I’ve been using wordpress on a blog and recently, I’ve started experiencing something strange only in Firefox. No other browser produces this problem, and it only recently started happening:

    When I go to any page on the website, it’ll add something like /#.TrHHL7L6Ph0 or /#.TrMD2bKwVic or some other random string following a hashtag to the end of whatever the original URL is, for example, it currently displays http://www.ccu.edu/news21/#.TrMQELL6Ph0 for me…

    I have 11 plugins right now, and I haven’t added or changed any of them recently. I don’t know what would be causing this problem and why it would only be a problem for Firefox exclusively.

    Can anybody give my some insight into what this is and how I can fix the problem?

    (Plugins I’m using: AddThis Social Bookmarking Widget, Akismet, All in One SEO Pack, BackupBuddy, cbnet Twitter Widget, CCU-TPG Get Posts, Enable Site Ping WPMU, Fast Secure Contact Form, Page Comments Off Please, PHP Execution, and Ultimate Google Analytics)

Viewing 8 replies - 1 through 8 (of 8 total)
  • Try deleting the Add This plugin.

    Thanks for the quick response!

    Removing the AddThis plugin did fix the problem.

    Just out of curiosity for my own future reference, do you (or anyone else) have any idea why that plugin would cause that problem?

    Bad coding within the plugin. The problem is most apparent in the Chrome browser but, more recently, has started to affect other browsers.

    I see. That’s kind of a bummer. You’ve experienced it before? Is there a way to fix it?

    Yes – I’ve seen it at least half a dozen times – always the same symptoms & the same plugin. The only way to get it fixed would be to try and contact the plugin’s developer.

    Ok thank you very much!

    This is related to the AddThis plugin, and even though the coding is that great it is actually related to a setting within the plugin.

    It is used to track address bar shares. You can turn off the setting by going to the AddThis setting page.

    From the Admin Dashboard:

    Settings > AddThis > Advanced Tab

    Uncheck the Track address bar shares option.

    THANK YOU! I was also looking for a solution to this hashtag problem. My nice clean urls are back after following the above advice.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Random Hashtag Strings Added to URL in Firefox?’ is closed to new replies.