WordPress.org

Support

Support » How-To and Troubleshooting » Random Fake Subdomains Redirect To My Index

Random Fake Subdomains Redirect To My Index

  • RandomWhim
    Member

    @randomwhim

    It’s not just http://www.mysite.com that goes to my WordPress index, anything else works too (random.mysite.com, asdfg.mysite.com, etc). I’ve searched the forums for something else like this, but I can’t find any advice for how to make such erroneous reqeusts to go to a 404 page.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Well, it’s not WordPress related. Just look at this example: free porn | free porn – this two link will take you to the same website. Why? 1. Domain configuration at DNS server – domain is configured as “wildcard” so anything.yourdomain.com will lead to your server 2. Server is configured so that it will take anysubdomain.yourdomain.com request and show your main page.
    How to disable it? You should be able to do this in control panel of your hosting account. If you can, ask your ISP. It may be possible to redirect such request to other page (e.g. mentioned 404) by using some server-side script, but it isn’t really a good solution.

    RandomWhim
    Member

    @randomwhim

    Thank you very much, pozmu! I could have spent hours messing around with WordPress files and configs. I’m very glad to know it’s my DNS Zone with my hosting company. Cheers!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Random Fake Subdomains Redirect To My Index’ is closed to new replies.