Support » Plugin: Publish To Apple News » Random API errors for social media links in post

  • HI
    getting random API errors stating URL for Facebook or Twitter should be valid URLs, while adding rel=nofollow tags properly.

    <a href="https://FBURL/" rel="nofollow">FBURL</a>

    should not generate an API error. Very very weird. Fully formed URL for href, and fully formed, or shorthand for on page text, does not seem to matter; have tried all usual suspects like broken HTML above the links – or curly quotes for HTML on the links, etc. But getting this randomly and only for social media links. Some ‘checker’ for social media URLs seems broken on/off with API check.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Kevin Fodness

    (@kevinfodness)

    Can you post the exact error message you are getting, please?

    neotrope

    (@neotrope)

    Hi,
    have not had issue since most recent plugin update, but I went back to one of the ‘problem’ posts and resaved; surprised I didn’t get a “item already synced” notice like new posts have when a typo fixed (ha, always something like CEO name!).

    Anyway .. I got this randomly on posts and could not solve issue with encoding of text, etc. — very weird.

    Anyway — not getting it lately, but here is the error:

    There has been an error with the API: INVALID_DOCUMENT - The value for the property "URL" at line 1 and column 4247 is not valid: TARAC WIPPP Facebook: https://www.facebook.com/taracwippp (keyPath components->3->components->7->URL), INVALID_DOCUMENT - The value for the property "URL" at line 1 and column 5377 is not valid: MIND THE GAP ® Facebook: https://www.facebook.com/MindTheGap (keyPath components->3->components->13->URL)

    neotrope

    (@neotrope)

    And the actual link looks like this

    Facebook: <a href="https://www.facebook.com/taracwippp/" rel="nofollow">https://www.facebook.com/taracwippp/</a>

    and

    MIND THE GAP ®
    Facebook: <a href="https://www.facebook.com/MindTheGap/" rel="nofollow">https://www.facebook.com/MindTheGap/</a>
    • This reply was modified 6 months ago by neotrope.
    neotrope

    (@neotrope)

    NOTE TO ADMIN — not promoting any FB page here, just debugging issue with API caused by a certain kind of FB link in WordPress main post editor.

    Using classic editor, not using Gutenberg.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Random API errors for social media links in post’ is closed to new replies.