Support » Fixing WordPress » Random 404’s when in the admin section

  • Resolved Vortex Radar

    (@ariel-b)


    So when I’m in the admin section on my website, whether it’s writing posts, checking stats, editing the widgets, updating plugins, or whatever else, often times I get a 404 error. Typically when I go back and try again, then I’m able to get to the page. When I’m making a change, sometimes the change gets executed despite the 404 while other times it doesn’t so I always have to go in and double check to see what happened after the error.

    I’m not sure what’s causing it, but I did notice the error starting after I changed web hosts. (I’m now using Dreamhost.)

    Any ideas what would cause frequent yet inconsistent 404’s in the admin section and not on the public facing posts and pages?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Have you checked your Apache error logs to see what might be causing the issue? In Dreamhost I believe those are stored in /your_user/logs/your_domain/https/…

    Often there is a plugin at fault for these types of errors, so you could also try disabling plugins one by one and see if that helps. Or you could try using a troubleshooting plugin such as https://wordpress.org/plugins/plugin-detective/

    Thread Starter Vortex Radar

    (@ariel-b)

    Good idea. I just took a look at the Apache logs and here’s one that I just got:

    End of script output before headers: update-core.php, referer: https://www.vortexradar.com/?s=update+core.php&search_404=1

    Googling a bit, it looks like it may be a permissions error which could have happened when I transferred files from one server to the other. It’s odd that the error happens only sometimes while other times it works fine though.

    OK, got it. Yes it’s not a bad idea to double-check permissions. If you’re on a shared or managed VPS server, you may need to contact Dreamhost to help with this. Generally, the correct file permissions for WordPress are:

    All directories should be 755 or 750.
    All files should be 644 or 640. Exception: wp-config.php should be 440 or 400 to prevent other users on the server from reading it.

    Changing File Permissions

    Thread Starter Vortex Radar

    (@ariel-b)

    I just went in to check. wp-admin/ was 755 and wp-admin/*.php were all 644. wp-config.php is 400. I redid the chmod again anyway just in case.

    Just putzed around a little more and I’m still getting the occasional 404.

    Hi,

    Yes, changing web hosts could cause 404s if not everything is migrated properly. First, check your wp-config.php and .htaccess file to make sure there is nothing pointing back to your old domain. What did you use to migrate your site or did your host take care of it for you?

    Make sure you have emptied your ccache since you migrated your hosts.

    You may also want to head to settings -> permalinks and then click the save button to make sure your .htaccess is written to correctly.

    Also there are a number of web results that could help you pinpoint this issue.

    https://bit.ly/2MWa8YW

    Let me know if this helps!

    Thanks!

    Josh

    Thread Starter Vortex Radar

    (@ariel-b)

    Hey Josh.

    So the domains themselves are the same. I don’t see anything referencing the specific server or its IP address.

    I migrated using VaultPress.

    Cache was definitely cleared.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    It looks like you also have WordFence – have you tried with it disabled? It may be mis-configured to point to the old file locations.

    Thread Starter Vortex Radar

    (@ariel-b)

    Ooh it looks like you’re right @ipstenu! I tried disabling it just now and am browsing around. The admin pages are all now just working with no mess and no fuss! Thank you! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Random 404’s when in the admin section’ is closed to new replies.