Support » Plugin: LiteSpeed Cache » Random 404 – manually reset permalinks

  • Resolved sgarcia513

    (@sgarcia513)


    This has been happening at random to multiple client sites where all subpages give 404 errors and I have to manually reset the permalinks. This started within the past month and I’ve had to disable Litespeed Cache as each one turns up. What I’ve noticed is the sites that get more traffic seem to fail quicker and more often as resetting the permalinks fixes it but will eventually fail.

    I have one client who has five websites and each one is failing but they’re entire business is through the sites so they get a lot of traffic. Sites on our server that don’t receive much daily traffic have not failed yet but I’m guessing they will at some point. Since these are happening on live sites, I can’t let it sit broken to diagnose.

    My guess is the htaccess file is getting corrupted at some point when the plugin is writing to it causing WP not to render out subpages properly.

    Thanks for any info you can give. Unfortunately I can’t confidently enable it on my larger clients until the plugin is more reliable.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    once you have configured the LSCWP without touch it , it won’t add or modify the htaccess.

    and LSCWP’s rule doesn’t effect on WP’s own rules.

    could you please try :

    1. when that happens , check the content of htaccess if it is still same as before.

    2. or, please try some security plugin that will disable write permission on htaccess and see how it goes.

    Does 404 happens randomly on different page ? or always same page/post?

    Best regards,

    • This reply was modified 1 year, 6 months ago by qtwrk.

    What I’m noticing is a list of backup htaccess files on the server. The three sites that were having troubles have at least 7 backups:

    .htaccess_lscachebak_01 through .htaccess_lscachebak_07 and a .htaccess_lscachebak_orig

    So unless something else is called “lscache” then it’s telling me the plugin is doing something with the htaccess files. I looked at the file dates and they’re usually grouped over a day or so, then nothing for a few months, then a few more.

    The sites that haven’t had any problem just have lscachebak_01 and _orig, but the sites that I’ve had to disable them have 7, 8 and 9 backups.

    For the sake of keeping my client happy, I’ve had to disable them on those sites.

    The 404 would happen on all subpages, not just a particular one. Resaving the permalinks page is the only way to fix it as it’s refreshing the WP portion of htaccess file.

    I am using iThemes security which does write to the htaccess file as well but we use both of these plugins in tandem on almost all of our sites. It is odd that the three sites with the most traffic are having this problem. The sites aren’t linked nor are they on the same account on our server; they’re three completely separate businesses but get a lot more traffic than every other site hosted by us.

    Hope this helps. I can send you a sample of the htaccess backup files if that would help as well.

    Thanks
    – Steve

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    No , these files are backed up files when you edit LSCWP configuration and it only happens when you change it , some features like browser cache , webp replacement , minify …etc that requires rewrite rule support.

    after you made all configuration and don’t change it anymore , LSCWP shall not touch htaccess anymore.

    This is weird issue , could you please try enable rewrite rule log on webserver? from there it might be tell us why it hits 404.

    Best regards,

    Plugin Support LiteSpeed Lisa

    (@lclarke)

    Hi,

    I’m going to mark this topic “Resolved,” due to lack of activity.

    If you still need help, we’ll be happy to reopen the topic. Please let us know what you’ve learned from the rewrite rule log, if so.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Random 404 – manually reset permalinks’ is closed to new replies.