Support » Fixing WordPress » Random 404 errors – Posts disappearing

  • I am using wp4.7. I am noticing that a post would disappear after a few hours and render 404 error instead!! It does not happen to all posts – which makes it even weirder. And it happens to posts that has displayed just mere hours previously!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi gbengalex,

    Oh no! That’s weird.

    Are you using any sort of plugin that can be used to set posts to auto-expire?

    And to be clear, you’ve definitely published these posts, rather than using a plugin like Public Post Preview, which uses expiring preview links?

    Thanks. I am investigating if my RSS feed aggregator is the culprit.

    Sounds good. I look forward to hearing of your findings.

    Was it the RSS? I’m having exactly the same problem, and it’s been a horrible headache for a few months now. Sometimes it’s even the homepage, so I’ve been getting a lot of complaints from the higher ups here.

    Hi Guys,

    I am having the same issue here…any updates on this?

    If you set your RSS feed aggregtaor to post a specific number of posts (say 100) it will auto delete previously posted content in order to keep maximum at 100. Those deleted posts will then return 404 error when browsed. I dont know which RSS plugin you are using but that seems to be the case with respect to WP RSS Aggregator plugin.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Random 404 errors – Posts disappearing’ is closed to new replies.