Support » Installation » Ran auto update for 3.1 and now site doesn't work (deleted mait mode file)

Ran auto update for 3.1 and now site doesn't work (deleted mait mode file)

  • I was just working with this site yesterrday. Sat down to continue the work and saw the update. Ran the update, it went into maintenance mode – fine, ok. Killed that maint file on the server, logged onto the server to give the directory full permissions. Went back into my WP admin and ran the auto update again. Said it completed fine but when I went to the front end it just does NOTHING (in IE).

    Firefox gives me this error… “Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

    I tried running the auto install a few times, all ‘completed’ – then I even went in and reverted back to the stock 2010 theme. Still nothing.

Viewing 15 replies - 1 through 15 (of 58 total)
  • Not sure if this additional info helps. As of yesterday I was ‘up to date’ with the most current version.

    This site is in a sub directory, and was moved there after it was installed – but I’m pretty sure I’ve run updates since then.



    Forum Moderator

    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides. You may need to access /wp-login.php to get this to kick in fully.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-running the upgrade manually using /wp-admin/upgrade.php.

    ESMI – I have full access to the server. So will go and try your suggestions.

    I was able to get the theme to change, and if I go in thru the admin, PAGES and click to ‘preview’ I can see the front end (in admin mode of course), and see the theme has changed.

    I will go give your suggestions a try though. In the meanwhile before you posted…

    I was going to go in and deactivate the few plug ins installed. Just out of curiousity I tried to run an update for a contact form plug in, it failed, then when I went back to view it in the plug in lists, it is totally gone. :-\ But the admin area let me deactivate all plug ins.

    ESMI – tried using FTP and could not change the plug-ins folder name to plugins.hold (or what ever it was the article suggested).

    I then went thru phpmyadmin and the setting was already a:0:{} (because as I said I was allowed to deactivate all my plug ins).

    Still no site on the front end. 🙁

    Ok, just for sh*ts N giggles I ran the auto update on our wordpress test site – same exact server but not running in a sub folder – and the result is the same.

    The site is dead. :-\

    Site A had minimimal plug ins installed and was running on a TemplateMonster theme.

    Site B was had 1 plug in (demo data) and was running on a 2010 child theme.


    Site B was just auto upgraded (same server settings etc) from 0.4 to 0.5 not too long ago and everything went fine, so I don’t get how it could be a permissions issue (just talking out loud).

    Ok – site B… I manually downloaded and uploaded all the 3.1 files manually and still no front end of the site.

    So then I went in and killed EVERYTHING. The database, all the files, and ran a totally new install on this. Created a new database, ran the install… still nothing on the front end. *sigh*

    Tried opening it in Chrome this time and got this error:

    his webpage has a redirect loop
    The webpage at http://ra-wordpress.com/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Here are some suggestions:
    Reload this web page later.
    Learn more about this problem.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

    Just another update (guess I’m just talking to myself at this point)

    I totally killed site B, all 3.1 files and the database, and did a resintall from 3.05 with a brandnew database. Works like a charm, like it was before this update.


    getting the same issues – “Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

    thank god i didn’t upgrade all my wordpress sites, although i’ve broken my most important/busy.

    You on windows server too?

    Yes… windows server.

    Same problem here with a windows server. I now have one useless site for my customer that doesn’t seem to work. Any suggestions people?

    Just wanted to chime in that I have the same problem, which is also a Windows server.

    I’m trying to disable all of my plugins, but it doesn’t seem to be helping so far. Guess we should all remove the latest update huh?

    All plugins disabled, reset them to Twenty Ten and still can’t access the site’s frontend.

    Guess I’ll be restoring from a backup until a fix is provided.

    I set up a totally FRESH install with a brand new database… with a totally new directory/domain name and it still produce the same error for me.

    So plug-ins shouldn’t be the issue – unless it is the plugins that come STOCK with the 3.1 download. :-\


    Shite. i forgot to do a backup. Any solutions people?

    I just made it work by using the following:


    Basically, download 3.0.5 IIS from the release archive: http://wordpress.org/download/release-archive/

    Delete all worpress files EXCEPT for the ones described in the “Upgrading WordPress Extended” article,

    Upload the 3.0.5 IIS zip file to your server, extract the files where WordPress is installed, and visit the site to do the “database upgrade” which is actually doing a downgrade.

    I also have MySql doing backups every night and I dropped all databases and restored from 2-16-11 (because my last file backup of the server was that day, I know, I know), but that probably doesn’t need to be done. In fact, I’ll probably restore last nights backup now.

    That should get you back up and running.

Viewing 15 replies - 1 through 15 (of 58 total)
  • The topic ‘Ran auto update for 3.1 and now site doesn't work (deleted mait mode file)’ is closed to new replies.
Skip to toolbar