Support » Plugin: Advanced Custom Fields » Radio Buttons Not Saving

  • Hi there,

    I have a problem in the Admin side of ACF. I have radio buttons showing on a standard post with 2 options, however if I select the second option and update the post, it will revert back to the first option being selected. I tried changing it to a drop-down field but encountered the same result.

    Is this a known issue or is this just something weird on my end?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Same behaviour here. Only saves after I change the option again and re-save the post.

    It’s actually worse than I thought. I created a new post, selected the desired radio button, saved the draft… all good. It was when I published the post that the radio button selected reverted back to the original setting. Very bad.

    My problem with the radio buttons seems to be fixed now.

    Try deleting radio custom fields, remove/reinstall the ACF plugin and deactivate all plugins, then reinstall plugin, reactivate all other plugins and re-setup radio button fields. It could’ve been upgrading to the latest version of the plugin that fixed it for me also, not exactly sure.

    The issue got a lot better for me after updating to version 5.7.7, but it’s still not 100% fixed.

    Sometimes, when I publish a post, my radio button’s selection changes back to the default/original setting. This is really bad.

    So maybe I got some data on the issue.

    Here’s how my custom fields are set up:

    I’ve just published a post in which imagem_topo wasn’t changed, so it was set to off.

    When I checked WordPress’ revision page…

    As you can see, it seems the value was changed from off to 0. Which doesn’t make any sense, of course.

    I won’t be able to help as your website is in another language that I can’t understand. But hopefully someone from ACF will address this issue eventually.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Radio Buttons Not Saving’ is closed to new replies.