Support » Plugin: Podcast Player - Your Podcasting Companion » Quotation marks and special chars problem in title

  • Resolved alex_pfa

    (@alex_pfa)


    I’m using the podcast player to show a RSS feed from my podcast.
    Now in the title the quotation marks and german special characters are shown wrong. As you can see below, in the description they’re shown correct.
    I don’t have an idea what it could be.
    Hope here is someone who can help.
    Thanks in advance
    Alex

    "Betriebsratsarbeit ist wie Fußballspielen" mit Thomas Steins
    „Betriebsratsarbeit ist wie Fußballspielen“ – So heißt das im März erschienene Buch von Thomas Steins, dem Gast

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author vedathemes

    (@vedathemes)

    Hi @alex_pfa ,

    Sorry for the late reply.

    Can you please provide your podcasting feed url? I will check and provide you a proper solution.

    Thanks,

    Thread Starter alex_pfa

    (@alex_pfa)

    Hi,

    no problem.
    The feed is
    https://aolqdn.podcaster.de/brconnect.rss

    Thanks
    Alex

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    Thanks for providing the RSS feed.

    I checked the feed URL. The title in the feed itself contains quotation marks (as shown in the screenshot https://www.dropbox.com/s/xvj0r6thpn701pw/img.png?dl=0). Therefore, it is displayed by podcast player as is. As you can see that the same text in the content is displayed correctly.

    Is it possible to correct the title text at source (in your feed URL)?

    Inform if you need any more help or explanation on the above.

    Thanks,

    Thread Starter alex_pfa

    (@alex_pfa)

    Hi Vedathemes,

    thanks for your fast help. I wrote to the podcast hoster (podcaster.de). They told me, that they have made some changes lately. For the normal german special chars, they changed the settings now a little bit, and it worked. Only the quotation marks have to be in this format for XML, and they cannot change. In their opinion, the player plugin has to support it.
    Do you see a change for this?

    Best ragards
    Alex

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    This usually never happened. The episode content is already having proper quotation marks inside the same xml file (as shown in my previously shared image). In my opinion, it can also be done with title easily.

    However, let me check how we can make it work with podcast player. Will get back to you by tomorrow. Sorry again for keep you waiting.

    Thanks,

    • This reply was modified 1 year, 3 months ago by vedathemes.
    Thread Starter alex_pfa

    (@alex_pfa)

    Hi,
    any news about this?

    Thanks
    Alex

    Plugin Author vedathemes

    (@vedathemes)

    Hi @alex_pfa ,

    I have created a modified version of podcast player to handle the issue. The official version will be released along with some other updates in a few days. Meanwhile, the following steps should help you,

    1. Backup your website.
    2. Download modified version of podcast player from https://www.dropbox.com/t/PDoxDm6pGoNV7ds6
    3. Replace currently installed podcast player with the above downloaded podcast player zip file (How?)
    4. Go to WordPress Dashboard > Podcast Player > Toolkit > Feed Updation tool.
    5. Select your podcast from the dropdown and click “Update Podcast” button.

    Now your issue should be resolved. Inform me for more help on this.

    Thanks,

    Thread Starter alex_pfa

    (@alex_pfa)

    Hi,
    worked perfect – the issue is gone.
    Thanks a lot
    Alex

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Quotation marks and special chars problem in title’ is closed to new replies.