Support » Plugin: Better Search » quotation marks

  • Harald Wenzel

    (@epiphanius1)


    Hello,
    thank you very much for you pluggin, to refine it further I want to report an issue: if I enter a serch term and put a quotation mark to it the result is an blank screen. Do you have any explanation for it?
    Thank you!
    Harald

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Ajay

    (@ajay)

    Can you tell me the search term you’re using exactly so I can test? I am not able to replicate that in my install.

    Harald Wenzel

    (@epiphanius1)

    Hello Aja,
    thanks for being so supportive!
    May I sugguest you go to w3punkt.de and try any string and add a ”
    Harald

    Harald Wenzel

    (@epiphanius1)

    Using: Enable seamless integration
    Enable search tracking X
    Stop search engines from indexing search results pages X
    Exclude password protected posts X
    Post types to include post X
    page X
    attachment
    glossary X
    Exclude password protected posts X
    Add nofollow to links X
    Theme Bhari-Child

    Plugin Author Ajay

    (@ajay)

    Thanks – I can replicate this but I have to say I am confused.

    Only things to try that I can think of:
    1. Upgrade to the latest version of Better Search (if not done already)
    2. Change to the default theme (Twenty Nineteen or any of those) and see if there is an issue
    3. Disable Better Search – does it work
    4. Keep Better Search enabled and disable other plugins (potentially ones that have some security checking)

    Worth also checking your logs on your server if there are any errors

    Harald Wenzel

    (@epiphanius1)

    Yes, I will try to find out, by now, I think of some secutity plugins blocking such character use. Thanks again, I will do an update if something comes out.

    Harald Wenzel

    (@epiphanius1)

    Hello Ajay,
    well be glad, its not your plugin’s disfunction but the plugin ‘WP Hide & Security Enhancer’. When I deactivate it, the search with ” is displaying normal results. But, I think I tried out every configuration option of WP Hide without finding the fault.
    Thanks so far!

    Harald Wenzel

    (@epiphanius1)

    Be glad, its the same with Relevansi! But your’s does a better indexing!

    Harald Wenzel

    (@epiphanius1)

    But Relevansi shows no results but a ‘page not found’.

    Harald Wenzel

    (@epiphanius1)

    Maybe there is a way to filte the quotation marks away? Or to exchange them for spaces?

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.