Support » Fixing WordPress » Quizzin 1.01.3 TinyMCE and Thickbox issue in WP 2.8.4

  • Resolved arax

    (@arax)


    There is a problem with TinyMCE and Thickbox JS in WP 2.8.4, in order for it to work you have to replace the following code in quiz_form.php and question_form.php:

    wp_admin_css('thickbox');
    wp_print_scripts('jquery-ui-core');
    wp_print_scripts('jquery-ui-tabs');
    wp_print_scripts('post');
    wp_print_scripts('editor');
    if(function_exists('add_thickbox')) add_thickbox();
    wp_print_scripts('media-upload');
    if (function_exists('wp_tiny_mce')) wp_tiny_mce();

    with this:

    wp_enqueue_script( 'common' );
    wp_enqueue_script( 'jquery-color' );
    wp_print_scripts('editor');
    if (function_exists('add_thickbox')) add_thickbox();
    wp_print_scripts('media-upload');
    if (function_exists('wp_tiny_mce')) wp_tiny_mce();
    wp_admin_css();
    wp_enqueue_script('utils');
    do_action("admin_print_styles-post-php");
    do_action('admin_print_styles');

    http://wordpress.org/extend/plugins/quizzin/

  • The topic ‘Quizzin 1.01.3 TinyMCE and Thickbox issue in WP 2.8.4’ is closed to new replies.