WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Quizz page just showing grey blocks

[Resolved] Quizz page just showing grey blocks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author jewlofthelotus
    Member

    @jewlofthelotus

    @khath Sorry to hear you’re having an issue with the plugin. I do see a few odd things going on.

    1) It looks like you’ve got two versions of jQuery loading on the page, the one loading from your Mango theme is pretty old and might be contributing to the problem. I’d try getting rid of that and seeing if it gets you any further.

    2) The SlickQuiz page elements seem to be getting wrapped in <code> tags for some reason. That will most likely prevent the quiz from displaying. I am not sure what would be doing this, possibly another plugin.

    So the first thing I’d try doing is finding the jquery.js include in your theme and removing that. It looks like it will likely be in the header.php template and will look something like:

    <script type="text/javascript" src="/wp-content/themes/Mangos/js/jquery-1.4.2.min.js"></script>

    Next, I’d start going through plugins one by one and disabling them then testing the quiz page again. Often times, other poorly-developed plugins will break other plugins entirely.

    Start with those and let me know where they get you. Thanks for trying out SlickQuiz!

    Thanks for your answer, it’s working well now !

    I give you some more informations on what I’ve done in case it could help you if some met the same problem.

    First, I tried to remove the 1.4.2 jQuery call. It makes the quiz appear and work, but breaks the slider on the homepage.

    Then I update jQuery to 1.10.2. Quiz was working as much as slider.

    For tags, I tried to disabled/enabled every plugins without any changes. Moreover, the tags position looks strange to me. In fact, the tags where around Slickquiz's shortcode ... I think they have been added when I pasted the shortcode. Just removed them.

    So, i feel like dumb cause the solution was pretty simple ^^.

    In all case thanks a lot for your help and your great plugin :)

    Plugin Author jewlofthelotus
    Member

    @jewlofthelotus

    Glad to hear you got it working! Interesting that the surrounding code tags had the effect that they did, but that’s good to know for future reference!

    Thanks for your help in figuring this out. And thanks for using SlickQuiz!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Quizz page just showing grey blocks’ is closed to new replies.