WordPress.org

Forums

Wp-Pro-Quiz
Quiz-button not working (5 posts)

  1. astrostart
    Member
    Posted 2 years ago #

    The quiz doesn't work when the shortcode is placed. I also tried the extra options - like the [raw]-mode - but it didn't work.

    Can someone please look at it and give me advise how to make it? Thanks in advance!

    http://www.scientias.nl/de-grote-new-horizons-pluto-quiz/90299?preview=1&_ppp=ef3ade5b15

    http://wordpress.org/plugins/wp-pro-quiz/

  2. xeno010
    Member
    Plugin Author

    Posted 2 years ago #

    Hello astrostart,

    you have a javascript error in "wp-content/themes/blacklight/includes/js/custom.js" line 89.

    Pls replace

    function iframe_correct(){
    	jQuery("iframe").each(function(){
    		var ifr_source = jQuery(this).attr('src');
    		var wmode = "wmode=transparent";
    		if(ifr_source.indexOf('?') != -1) {
    			var getQString = ifr_source.split('?');
    			var oldString = getQString[1];
    			var newString = getQString[0];
    			jQuery(this).attr('src',newString+'?'+wmode+'&'+oldString);
    		}else{
    			jQuery(this).attr('src',ifr_source+'?'+wmode);
    		}
    	});
    }

    TO

    function iframe_correct(){
    	jQuery("iframe").each(function(){
    		try {
    			var ifr_source = jQuery(this).attr('src');
    			var wmode = "wmode=transparent";
    			if(ifr_source.indexOf('?') != -1) {
    				var getQString = ifr_source.split('?');
    				var oldString = getQString[1];
    				var newString = getQString[0];
    				jQuery(this).attr('src',newString+'?'+wmode+'&'+oldString);
    			}else{
    				jQuery(this).attr('src',ifr_source+'?'+wmode);
    			}
    		} catch (e) {}
    	});
    }

    and try again

    xeno010

  3. astrostart
    Member
    Posted 2 years ago #

    Hi Xeno010,

    Thanks for your support! I changed the custom.js. Unfortunately it didn't worked :-(

    Do you have another idea? Thanks in advance!

    Best regards,
    Tim Kraaijvanger

  4. xeno010
    Member
    Plugin Author

    Posted 2 years ago #

    OK, the error has been corrected in custom.js.

    Step 2:

    Pls go in your Adminpanel:
    -> Adminpanel
    -> Wp-Pro-Quiz
    -> Global settings (Overige instellingen)
    -> Settings in case of problems (Instellingen in geval van problemen)
    -> activate the "Do not load the Javascript-files in the footer" option (Javascript-bestand is niet geladen in de footer)

    and try again

    Best regards,
    xeno010

  5. meenalok
    Member
    Posted 1 year ago #

    My website is http://www.quizdesire.com.
    Same problem here. Sometimes the start button is working and sometime not. Please help me soon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Wp-Pro-Quiz
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.