Support » Plugin: NextScripts: Social Networks Auto-Poster » Quick Post Error – Unable To Post Images to Twitter

  • Resolved drinxx

    (@drinxx)


    This new version is ruining my website and ability to use Quick Post. This was obviously not ready to come out of beta. Please post a download link to revert back to older version.

    Error when trying to Quick Post to twitter with an image….

    -=ERROR=- Array ( [pgID] => [isPosted] => 0 [pDate] => 2017-10-20 01:00:19 [Error] => Resp: {“errors”:[{“code”:44,”message”:”media_ids parameter is invalid.”}]}|

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author NextScripts

    (@nextscripts)

    Do you have the URL to the valid image in the “Image Post” field?

    Thread Starter drinxx

    (@drinxx)

    Yes. Been using Quick Post for a long time. Very familiar with how to use it. Everything is set up correctly. Image link is in the correct field.

    Thread Starter drinxx

    (@drinxx)

    Same Quick Post posts successfully to other pages just fine. Only gives error with TW

    Thread Starter drinxx

    (@drinxx)

    Our entire website operates off of being able to post deals to all social. Snap worked great for several years. Now with the changes, it’s confusing and not functioning properly. It has brought our business to a halt! Very disappointed. Is there a way to revert back to the older version?

    • This reply was modified 4 years, 11 months ago by drinxx.
    Plugin Author NextScripts

    (@nextscripts)

    We can’t replicate this. Please contact support directly with your site info. It seems like I need to take a look at your environment.

    Thread Starter drinxx

    (@drinxx)

    ok.. I will do so shortly. I never had issues before this update.

    Plugin Author NextScripts

    (@nextscripts)

    Well for the last 5 years we were using “update_with_media” API endpoint.

    https://developer.twitter.com/en/docs/tweets/post-and-engage/api-reference/post-statuses-update_with_media

    Recently Twitter put this message there:

    POST statuses/update_with_media (deprecated)

    This endpoint has been DEPRECATED should no longer be used. This endpoint does not support multiple images, animated GIFs, or video. Replacement method: follow the Uploading media guide to upload one or more media entities, and then use POST statuses/update to attach them to a Tweet.

    So we had to update our code and switch to “Replacement method”. Your error “media_ids parameter is invalid” is coming from that “Replacement method”.

    Plugin Author NextScripts

    (@nextscripts)

    We found the issue. Will be fixed in the next release.

    Thread Starter drinxx

    (@drinxx)

    Thank you. 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Quick Post Error – Unable To Post Images to Twitter’ is closed to new replies.