Support » Fixing WordPress » Quick Edit not working after 3.5 update

  • In “All Posts”, the “Quick Edit” link doesn’t do anything. Also, when editing a post, I can’t change the status, visibility, or timestamp of the post… The “Edit” link doesn’t do anything.

    Is this a problem for anybody else? Could someone help me? I heard there were some issues with the BulletProof Security plugin, but I have never used that plugin before.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Can you try the steps on http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors and let us know what steps (if any) help to rectify your issue?

    Yes, I am having an identical problem after my upgrade to 3.5 with “quick edit” and publishing options in posts. Also, I cannot edit the Permalink.

    I use Chip-life Theme 1.4.3 and have All in One SEO and Quick Cache installed.

    I use Firefox and have also tested the upgrade on a separate “clean, History free Chrome Browser” but the problem remains.

    Script Debugging Solved the problem. Where in the Support Forum do I go to notify of this issue?

    Can you please try going through the steps at the link above and see if they help assuage the problem for you?

    George, Sorry, see above. I edited my post to say that Script Debugging Did solve the problem. Now I juts need to know where in the support forum to let them know.

    Ah, thanks! Sorry, I may have misread too quickly.

    Could you

    1) Turn script debugging back off,
    2) View the source of the problematic page, and
    3) Find the tag in the page source that looks something like

    <script type='text/javascript' src='http://stephanis.info/wp-admin/load-scripts.php?c=0&load[]=jquery,utils,json2&ver=3.6-alpha'></script>

    and paste the src in here, so we can see where it’s failing?

    (as in, paste the URL to the src, so we can check for ourselves for error messages or a malformed url)

    Script Debugging also worked for me. Who should we report to?

    This thread is fine to report it in. I’m keeping tabs on it, and will bring it up tomorrow afternoon at the dev meeting.

    EricDLee — if you could follow the steps I mentioned above to give me a URL, it would be very helpful in tracking down the issue.

    If you’d rather not share the URL to your site publicly, if you could email it to george at stephanis dot info, that’d be just as good.

    George, is this what you are after:

    <script type=’text/javascript’ src=’http://www.gamesfromeverywhere.com/wp-admin/load-scripts.php?c=0&load[]=jquery,utils&ver=3.5′></script>

    Yup, that’s it, but *hrm* no problems there. Any chance you could take a screenshot of your JS console with the errors showing?

    Sorry to be a bother, and thanks!

    George, you are not a bother. You are an excellent help. Thing is, I do not know what a JS console is!

    George, the following Plug in is to blame:

    kk Star Ratings

    I have deactivated it. Should I notify anyone (apart from the developer) so that others will know?

    Script debugging did not work for me. Any other fix to be able to use Quick Edit? Adding a link via the short link also isn’t working.

    Can you make me a ‘contributor’ level account and email the credentials to [ redacted, support is offered via the forums and not email ] ? It’ll let me check it out and take a look for the js conflicts that are causing the issue.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Quick Edit not working after 3.5 update’ is closed to new replies.