WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Quick edit excerpts won't save

[Resolved] Quick edit excerpts won't save

  • gillespieza
    Participant

    @gillespieza

    Excerpts I enter using the quick-edit feature are not saved. I have no custom posts, am using the plugin solely for the quick-edit excerpt function.

    I have enabled excerpts in the settings, but if I click Quick Edit, enter some text in the excerpt box, and click update, the excerpt disappears if I look again.

    Please advise?

    http://wordpress.org/plugins/custom-bulkquick-edit/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Michael Cannon
    Member

    @comprock

    I’ll need to debug on your system. Could you please open a support ticket via support@aihr.us and include an admin login?

    Don’t forget to reference this link.

    Thank you.

    gillespieza
    Participant

    @gillespieza

    I think I have narrowed down the problem – Quick Editing the excerpts works just fine until I enable the plugin “Threads” (http://wordpress.org/plugins/threads/).

    Plugin Author Michael Cannon
    Member

    @comprock

    Beyond this, are you still having troubles?

    gillespieza
    Participant

    @gillespieza

    Nope – it works perfectly without the Threads plugin. Of course I don’t expect you to have to fix a plugin conflict. I am currently looking for a replacement for Threads, failing which I will dig into the code and hope it’s decently commented and see if I can’t find where the problem is. Possibly a duplicated function name (the Threads plugin puts the thread taxonomy in Quick Edit as well)?

    [EDIT] So I think the conflict might have come with the save_post hook – both plugins remove the action and then re-add it. Threads used priority 10, yours uses priority 25. By changing the Threads priority to 26, now it all works fine 🙂

    Plugin Author Michael Cannon
    Member

    @comprock

    Sweet to know the fix. Nice job figuring it out.

    wanderingjen
    Member

    @wanderingjen

    Hello!

    I run http://www.explorebuxtonderbyshire.co.uk and the excerpt will no longer allow me to either edit or add new excerpts to posts on the ‘quick edit’ option. It will only allow me to do once ive clicked into each individual post – which is much more time consuming. The quick edit option is great to add the excerpts when i go the entire list of posts and i can do lots in a short space of time – alas – no more. When i do try and edd text in the quick edit option it just totally disappears and any changes made to new ones – the changes are lost. Can you help please? This has become a key feature of my site so would ideally like this fixed…thanks in advance!
    Jen 🙂

    Plugin Author Michael Cannon
    Member

    @comprock

    Jen, Please open a new thread.

    wanderingjen
    Member

    @wanderingjen

    Cool, just doing it now 🙂
    Thanks!
    J

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Quick edit excerpts won't save’ is closed to new replies.