WordPress.org

Support

Support » Plugins and Hacks » [Resolved] quick edit, drop down list and hide button not working

[Resolved] quick edit, drop down list and hide button not working

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Known issue that I can’t fix at the moment. Google’s +1 code isn’t compatible with the latest jQuery.

    RavanH
    Participant

    @ravanh

    Ahhhh, just came here to report the same thing… Good to know, I’ll advise users to disable the button for now 🙂

    But there are some strange things though… For one, I get this issue only in Chrome but not FireFox or Opera. And in Chrome every page in the admin trows this error

    Uncaught TypeError: Illegal invocation - cb=gapi.loaded_0:202
    I.g.H - cb=gapi.loaded_0:202
    sgc_renderplusonepreview - index.php:53
    (anonymous function) - index.php:57
    l - jquery.min.js:2
    c.fireWith - jquery.min.js:2
    v.extend.ready - jquery.min.js:2
    A - jquery.min.js:2

    except one page: Settings > Simple Google Connect !

    The Simple Google Connect admin page does include the usual

    <script type="text/javascript">
    function sgc_renderplusonepreview() {
    		var params = [];
    		params['size'] = jQuery('input:radio[name="sgc_options[plusone_layout]"]:checked').val();
    		params['annotation'] = jQuery('input:radio[name="sgc_options[plusone_annotation]"]:checked').val();
    		params['href'] = "http:\/\/domainedeschenes.status301.net\/";
    		gapi.plusone.render('plusonepreview', params);
    }
    jQuery(document).ready(function() {
    	jQuery('input.sgcplusone').change(sgc_renderplusonepreview);
    	sgc_renderplusonepreview();
    });
    </script>

    but still the error is gone and the menu drop-downs and other stuff is working again.

    Weird.

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Crap. Okay, I know what the issue is. I’ll see what I can do.

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Temporary fix that seems to work for me, add the given lines to the top of the sgc_plusone_preview_script() function.

    http://plugins.trac.wordpress.org/changeset/669963

    This makes it not load that script anywhere but on the sgc settings page, eliminating that error. I do not know if this will fix any other problems elsewhere in the admin, but it might.

    RavanH
    Participant

    @ravanh

    So far, I can see no issues anymore… Excellent! 🙂

    Vakantie Ameland
    Member

    @christianebuddy

    This did the trick Tnx!

    sanjeet.bisht
    Participant

    @sanjeetbisht-1

    thanks a lot done 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] quick edit, drop down list and hide button not working’ is closed to new replies.