Support » Plugins and Hacks » [Resolved] Quick Edit broken ONLY in the pages

[Resolved] Quick Edit broken ONLY in the pages

  • Hello all,

    Could one of you explain to me why Subscribe2 breaks Quick Edit BUT ONLY on the pages’ page???? It works perfectly fine in the posts’ page.

    Also, with the break, the grey bar (do not know the name) at the top of the admin, with the menus, and the +New and the profile/logout access possibility disappears too…

    It is the only plugin doing that, no matter which theme I use, btw.

    Thank you!

Viewing 15 replies - 1 through 15 (of 16 total)
  • @midori,

    I have a test install of WordPress 3.3.2 with Subscribe2 8.2 as the only active plugin.

    I am finding no issues or errors in the Quick Edit button for posts or pages.

    This may be to do with your theme, I am using TwentyEleven on my test site.

    As I said, I tried with TwentyEleven and even Twenty Ten with no better result. And yeah, it might have been a combination of plugins, except I deactivated everything, tried so, and the only times that Quick Edit fail happens is when I activate Subscribe2 (8.2).

    One thing I should say, though, is that my WP is the French version, and Subscribe2 was also a French version, that is until it upgraded.


    For the French version of the plugin are you using the gettext mo files or is it a version that’s been hard translated in the code files?

    Heee, it is a version that I found in one of the threads of this forum, I installed the zip, it did work, except as soon as I refreshed the page, I got an “update” warning, lauched the automated installation, and promptly got the English version of the plugin again… I did not check further, but I think it included mo/po except in the root of the plugin instead of a folder…

    Because of that, I am going to try with deleting the plugin and installing the English clean last version. I’ll keep you posted.

    Nah, no difference. By the way, apparently, everything relying on ajax seems wonky (help menu, appearance settings, quick edit, …), but again, ONLY on the page listing the pages. Not even on the page listing the unpublished pages, … no, really ONLY on /wp-admin/edit.php?post_type=page which is really, really weird.


    What’s even more weird is that I don’t think Subscribe2 even pushes any code into that page!

    Are you getting any errors in your browser console?

    Yeah, I did not think it would either. And yeah, I get errors. There you are:

    Makes no sense, and why would it be different for posts and unpublished pages and…


    Hmm, those look like Web Console error messages in the js and css. They are no different from what I’m getting.

    Are there any entries in the Error Console?

    4 times something like `Timestamp: 14.05.12 23:15:54
    Warning: Expected ‘,’ in media list but found ‘and(‘.
    Source File: http://www.doctor-who.fr/wp-admin/load-styles.php?c=1&dir=ltr&load=admin-bar,wp-admin&ver=7f0753feec257518ac1fec83d5bced6a
    Line: 2`

    All the rest are the same CSS problems as in the screenshot. Does it help?


    I’m getting those same errors in my console – I think they are coming for the WordPress core files and are related to the admin menu bar.

    Ah, ok, that would explain the quick edit problem, if the code is broken before arriving there. Hm, I am going to post an error report, then, unless Subscribe2 does modify said bar?


    Hmm, it’s a warning rather than an error so I’m not sure that this is what’s stopping your Quick Edit from working. Also, the warning is present on a clean install of 3.3.2 with no plugins running at all.

    Weird. If I deactivate Subscribe2, I still get the warning, but the bar appears. I am lost, now. It makes no sense at all.


    It’s a long shot but I wonder if one of the WordPress or Subscribe2 files are corrupt. Can you reinstall WordPress and upload (via FTP) a fresh copy of Subscribe2?

    Sorry, I was extremely busy off-web. Yes, I can, and I will, though not today, and will keep you posted. Thank you for your help, anyhow, and all the admins love the plugin!

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Quick Edit broken ONLY in the pages’ is closed to new replies.
Skip to toolbar