WordPress.org

Forums

Quick Cache (Speed Without Compromise)
[resolved] Quick Cache not working (20 posts)

  1. eatnabout
    Member
    Posted 1 year ago #

    Hi I installed Quick Cache today but am having difficulty getting it to work. I have some files in the cache directory however when I view page source no notes are shown at the </html> tag.

    Also seositecheckup.com is still giving me 0% for caching ("It does not appear that you are caching your pages") as well as webpagetest.org giving me an F for Cache static content.

    Plugin is enabled, I've logged out of my WP, cleared cache, tried various browsers when viewing my page source. I'm not running any of the listed incompatible plugins. I've checked the PHP error log on my server and there are no errors for Quick Cache. I also have the option set to allow caching in client side browser.

    The site is http://eatnabout.com

    Thanks in advance for your help!

    https://wordpress.org/plugins/quick-cache/

  2. ferdienandp
    Member
    Posted 1 year ago #

    oh i got the same problem..

  3. raamdev
    Member
    Plugin Author

    Posted 1 year ago #

    @ferdienandp I responded to you on your thread.

    @eatnabout It sounds like you're doing everything right. The next step is to rule out a plugin or theme conflict. Can you provide me with a list of plugins that you're using?

    Also, it looks like you're running the Weaver II theme. Can you open your Weaver II Admin page, and open the “Advanced Options -> Site Options” tab and tell me if you see anything about Quick Cache in there?

  4. eatnabout
    Member
    Posted 1 year ago #

    Sure, here's the list of plugins:

    Add from Server
    Akismet
    CloudFlare
    Contextual Related Posts
    Custom Post Limits
    EWWW Image Optimizer
    Facebook Likes You!
    FitVids for WordPress
    Google Analytics Dashboard for WP
    Google Analytics for WordPress
    Import External Images
    iThemes Security
    Jetpack
    jQuery Colorbox
    Link Manager
    mobble
    No Title Tooltips
    Restrict Widgets
    Shareaholic
    Simple 301 Redirects
    Weaver II Theme Extras
    Widget Logic
    WordPress SEO
    WP-Optimize
    WPBeginner's Compact Archives
    WP Widget Cache

    My Drop-ins folder shows advancedcache.php and the code in there is related to QuickCache. Also the Advanced Options in Weaver II Admin say Automatic support for Quick Cache has been enabled.

  5. raamdev
    Member
    Plugin Author

    Posted 1 year ago #

    Can you try disabling CloudFlare and see if that makes the Quick Cache notes reappear in the HTML? I noticed when looking at the HTML for your site that there are 4 blank lines at the very bottom, exactly where I'd expect to find the Quick Cache notes. That makes me suspect that Quick Cache is in fact running just fine but that something is stripping out the comments from the HTML.

    Do you know if your web host is doing any server-side caching or optimization?

  6. eatnabout
    Member
    Posted 1 year ago #

    I disabled CloudFlare and the Quick Cache notes then displayed in the page source. So I'm not sure what's causing it but it must be a conflict with CloudFlare. Is there a way to test while CloudFlare is active to make sure Quick Cache is serving cached pages?

  7. raamdev
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like the CloudFlare plugin has a Development Mode option that when enabled will bypass CloudFlare's accelerated cache. Enabling that should prevent CloudFlare from stripping the Quick Cache notes from the source code so that you can verify it's working.

    Please see https://support.cloudflare.com/hc/en-us/articles/200168246-What-does-CloudFlare-Development-mode-mean-

    Can you try that and let me know if that works?

  8. eatnabout
    Member
    Posted 12 months ago #

    Yes, the notes display in Development Mode so I take it this was just an issue of CloudFlare stripping what it deems as unnecessary HTML and that Quick Cache is actually still running with CloudFlare enabled. Thanks for all your prompt replies.

  9. raamdev
    Member
    Plugin Author

    Posted 12 months ago #

    My pleasure! :) I'm glad we got this resolved.

  10. Andreas
    Member
    Posted 5 months ago #

    Hello Raam,

    I have a similar problem, also using Cloudflare. I enabled development mode, also completely paused its usage, however i don't see anything unde the </html> tag.

    In addition, i don't think the plugin is working, since load time has not been reduced and page speed still says i should leverage browser caching!

    To be honest, I was always using wp-super-cache, however at some point it stopped working! No i am trying to get quick cache to work, with no luck which leads me to believe something is messing with cache on my website! A very similar(not entirely the same..same plugins,same theme, different WP version), backup version of the website i have seems to have no problem caching, however my live one does!

    Do you have any idea what i should be looking for? Is there really something that could be messing with website caching?

    p.s. If you would like to take a look at my website please let me know

  11. Andreas
    Member
    Posted 5 months ago #

    Sorry for double posting, just wanted to add: I have already tried disabling all plugins with no luck.

  12. raamdev
    Member
    Plugin Author

    Posted 5 months ago #

    Do you have any idea what i should be looking for? Is there really something that could be messing with website caching?

    It sounds like your web host might be interfering here. I suggest opening a support ticket with your web hosting company and asking them about what might be going on.

    In the future, please open your own support thread, as this thread has already been marked as resolved.

  13. Lengem
    Member
    Posted 4 months ago #

    My server runs PHP Version 5.3.29, but Quick Cache refuses to activate displaying the following message:

    "Quick Cache is NOT active; Quick Cache requires PHP v5.3 (or higher). You're currently running PHP v5.2.17. A simple update is necessary. Please ask your web hosting company to do this for you. To remove this message, please deactivate Quick Cache."

    Please help.

  14. raamdev
    Member
    Plugin Author

    Posted 4 months ago #

    @Lengem Your web host needs to fix this for you. Please open a support ticket with your web hosting company and ask them to upgrade your account to PHP v5.3+.

  15. Lengem
    Member
    Posted 4 months ago #

    Thank you Raam for your quick reply.

    As I mentioned in the beginning of my previous post, my server runs PHP version 5.3.29. I can provide the screenshot of my cPanel saying PHP version 5.3.29, Apache version 2.2.29, MySQL version 5.5.38.

    I don't know why QC detects my PHP version as 5.2.17 and refuses to activate?

    Please help.

    Lengem

  16. Lengem
    Member
    Posted 4 months ago #

    Hello Raam,

    My hosting company just sent me an email saying they have upgraded my account to PHP v5.4.33. I checked the phpinfo.php. It confirmed the PHP version is 5.4.33.

    I reinstalled Quick Cache. Activated it. The same message appeared complaining my server is running PHP v5.2.17 !!!

    Please help

    Lengem

  17. salem80
    Member
    Posted 3 months ago #

    I found solutions to enable Quick Cache
    Edit your wp-config.php and delete WP-Super Cache line
    define( 'WPCACHEHOME', '/WP-Super Cache-pathe' );
    and then re enable Quick Cache again it's work now .

  18. kimmer99
    Member
    Posted 1 month ago #

    Bumping this as I'm having the same issue as Lengem, getting this message:

    Quick Cache is NOT active; Quick Cache requires PHP v5.3 (or higher). You're currently running PHP v5.2.17. A simple update is necessary. Please ask your web hosting company to do this for you. To remove this message, please deactivate Quick Cache.

    But my cpanel shows:

    Apache version 2.2.29
    PHP version 5.4.24
    MySQL version 5.5.40-36.1-log

    Looked in my config file as salem80 suggested but I have no such line in my wp-config.php file.

    Any other ideas? Thanks!

  19. MassimoD
    Member
    Posted 1 month ago #

    @kimmer99

    Check your site HERE:

    http://www.wmtips.com/tools/info/

    What php version it reports ?

    Cpanel may say PHP 5.3 but what have you as default ? I BET you have 5.2.

  20. kimmer99
    Member
    Posted 1 month ago #

    Thanks Massimo, though the cpanel said I was 5.4 you were right the default was 5.2! I just now changed it and was able to use the plugin.

    Thanks again! :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.