WordPress.org

Forums

Question about wordpress pages and associated template files (4 posts)

  1. Dorza
    Member
    Posted 10 months ago #

    Hi Everyone,

    I am a bit confused about how wordpress pages work and template files. I have a few questions about wordpress pages and template files. The url of my wordpress site is http://www.ostech.com.au/ and the theme I am using is bluefantasy.

    My first question is what template file gets brought up if I type http://www.ostech.com.au in the browser and press enter? page.php or index.php or both or some other template file?

    My next question is if I created the home page content from the page editing creating area and created a permalink for it in wordpress rather than doing it all in the index.php file will there be a difference in positioning and styling?

    The reason why I am asking these questions is because if I have the homepage link as the url link to the website http://www.ostech.com.au/ the homepage functions as it should. If I however change the homepage link to a permalink to wordpress page generated in the wordpress page creation editor the hover text doesn't appear behind the product boxes when you hover over them as it should.

    I appreciate if someone could help me with this as soon as possible. It is an urgent matter. Is this Topic question in the section?

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    My first question is what template file gets brought up if I type http://www.ostech.com.au in the browser and press enter?

    That depends on whether you are using a static front page (in which case it would be page.php) or a posts page (index.php).

    What theme are you using? Where did you download it from?

  3. Dorza
    Member
    Posted 10 months ago #

    The theme I am using is bluefantasy from wordpress.

  4. Dorza
    Member
    Posted 10 months ago #

    The authors homepage is WPart.org. I am not using a static page. When I switch to a static front page that is when the hover text behind the product boxes disappears and doesn't show when you hover over them.

    [ No bumping please. ]

Reply

You must log in to post.

About this Topic