Support » Plugins » Hacks » Question about Pagination

  • Resolved creativelifeform


    Hi there, I’ve just come across a problem I haven’t experienced before, perhaps I modified something I shouldn’t have…

    Anyway, I have set the maximum number of posts per page on the site I’m working on to 5. All good, only 5 show up. However, now when I press the “Show previous posts” button, I get a 404, meaning that perhaps the template which searches for older posts within the category has been edited incorrectly. I’m not sure which template this comes from however. I’ve basically modified everything, including category.php and loop-category.php but I can’t find anything in the original theme files that would suggest the result would change if I reverted to these. Can anyone help?

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Interestingly enough, changing my template back to the default does not fix the issue. Very strange…

    Okay, it has something to do with the permalink structure. Now if I go and change the permalink structure to the default setting, everything works fine. But I don’t want to have to do that. This is an incredibly bad problem which, to be honest, I’ve not run into before now oddly enough. Perhaps this is a 3.2.1 thing?

    One more note, I have just recently completed another site which used exactly the same permalink structure, and it worked perfectly fine the only difference is that get_next_post() was being called on the index.php file and not on the loop-category.php file.

    Sorry for posting like a madman, just updating as I investigate this. So basically, this is a permalink issue, but what is really weird is the only permalink structure that seems to have an issue, is /%category%/%postname%/
    If I use any of the predefined ones, it’s fine. If I use simply /%postname%/
    it’s fine. Finding this really weird, and irritating considering the first example really is the preferred permalink structure. I began to get suspicious however when the blog category homepage was simply /category-slug instead of /category/category-slug like it usually is with this install. Hoping someone has a fix for this.


    OKAY fixed the problem. The issue was due to a wrong file path for my category. As I mentioned before, I was using /category-slug instead of /category/category-slug, don’t ask me why, never done this before. Anyway as soon as I switched it to /category/category-slug it worked fine. My bad, issue resolved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Question about Pagination’ is closed to new replies.