Support » Plugin: WordPress Backup to Dropbox » Question about first full backup – worked, but got error in log

  • Resolved DLo978


    Question. I have this plugin installed with the zip premium extension. My understanding is that the first backup is a full backup, and then the following backups are incremental. Is this correct?

    Also, I ran my first backup and the result was good. I have a 387MB zip file with my code and sql files for the database. But I noticed the following in the backup log (I removed some identifying info):

    16:29:09 : A total of 20MB of memory was used to complete this backup.
    16:29:09 : A fatal error occured: Submitted input out of alignment: got [109051904] expected [104857600] (Status Code: 400)
    16:26:57 : Uploading /******/html/wp-content/backups/ in chunks.
    16:26:57 : A total of 5909 files were processed.
    16:26:47 : Approximately 95% complete.
    16:26:41 : Backing up WordPress path at (/*******/html/).
    16:26:41 : Creating zip archive.
    16:26:28 : Creating SQL backup of your WordPress plugins.
    16:26:27 : Creating SQL backup of your WordPress core.
    16:26:12 : There has been no backup activity for a long time. Attempting to resume the backup.
    16:20:34 : Uploading /*********/html/wp-content/backups/ in chunks.
    16:20:34 : A total of 5909 files were processed.
    16:20:24 : Approximately 95% complete.

    After it tried to upload the zip file in chunks, it seemed to timeout and start over. Then there is a fatal error, and then supposedly completes. Thankfully, it seems to have worked because I have a full zip file with the backup. But, I’d like to understand the process and what the error is and fix it, since I will be relying on this to protect my blog.

    Appreciate any help, on what seems to be a very helpful plugin (assuming I can get this bit squared away).


Viewing 1 replies (of 1 total)
  • Plugin Contributor Michael De Wildt


    Your blog is one of the largest I have seen use my plugin to backup.

    It looks like your upload is timing out and the backup is attempting resume uploading from the beginning of the zip file hence the fatal error.

    I would not trust that zip file because I doubt all the contents will be there. I need to implement a smarter mechanism to resume when a timeout occurs in the middle of a chunked upload.


Viewing 1 replies (of 1 total)
  • The topic ‘Question about first full backup – worked, but got error in log’ is closed to new replies.