Support » Plugin: Companion Auto Update » question about commercial theme updating

  • Resolved flamenco

    (@flamenco)


    Hi,
    My client’s site went down yesterday. After reading the error message, I figured out that the site’s parent theme, Genesis, was gone. I re-installed Genesis, and all was well. Also, the log said that Genesis had been updated! Btw, Companion did successfully update a plugin the same day.

    The site is hosted on Godummy, er, I mean, Godaddy, and I understand that auto-updating doesn’t always work there. So maybe that was part of the scenario.

    I’ve never had such a thing happen before. I have seen that Companion doesn’t update commercial themes. That said, Genesis did have a new version that just came out, and I’m wondering – could that have accidentally triggered an update that could delete that folder? It looks that way in the log.

    I’m also wondering if I should turn off updating for commercial themes and commercial plugins to be safe?

    Thanks for your excellent work! Dave

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Papin Schipper

    (@papin)

    Hi,
    This plugin should completely skip anything that isn’t on the WordPress.org repositories (any premium plugin or theme). I did notice that Genesis has it’s own updating feature so maybe that’s turned on?

    If the Genesis option is turned on my guess is that it started updating but your server ran into an issue (memory related?) and stopped halfway through.

    The log will show any update, even the ones not done by Companion so that’s why it showed up there.

    To be safe you could always turn it off ofcourse.

    Hi!
    Great answer, thanks. Yeah, I forgot that Genesis has its own update setting.

    Also, good thought about timeouts, especially on Godummy, which is very stingy with resources!

    One more little thing that may be helpful… under Possible Plugin Issues and “You’re using one or more plugins that might cause issues.”, the link to “How to Fix” gets a 404.

    Thanks again!
    Dave

    Plugin Author Papin Schipper

    (@papin)

    Woops, fixed the 404 error 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.