Support » Plugin: qTranslate X » query_posts problem

  • Resolved elsnare

    (@elsnare)


    I have a custom post type query which displays the posts. Some posts have content in 2 languages, some only in 1.

    The problem: When switching languages the posts with single language content are always visible in the list. The title and prefix changes and the excerpt changes to: “Sorry, this entry is only available in…”.

    What do I need:To posts that have no content in language X to not display when language X is selected.

    https://wordpress.org/plugins/qtranslate-x/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Gunu

    (@grafcom)

    @elsnare,

    Can you show me a link where I can see the problem?

    Hi Gunu!

    You can see the list here: Click

    The query is a standard one:

    $args=array(
    'paged'=>$paged,
    'post_type'=>publikacje,
    'order'=>DESC,
    );

    Something as simple as “if current language X, hidde content in Y” would suffice, that I could run through the results.

    Plugin Author Gunu

    (@grafcom)

    @elsnare,

    try – Hide Content which is not available for the selected language – Unchecked

    Settings – Languages

    As of now it is currently checked – the content vanished but the post is still present 🙂

    I’ll give something a try now..

    Ok. So the Hide Content worked as it should – it filtered out the posts.
    The posts that were left – I just re-published them and that assigned the correct languages to them.

    So as now everything works as it should. Thanks for the help, great plugn, great support.

    Plugin Author Gunu

    (@grafcom)

    You are welcome!

    You can review this plugin to help other people to find out the value.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘query_posts problem’ is closed to new replies.