Support » Plugin: Plugin Load Filter » Query String Disable Plugins

  • Resolved Tim Dueck

    (@duecktimothy)


    Hello,

    Once again, love this plugin! I’m having an issue with URLs that contain query strings at the end. It seems that if a query string is added than all the plugins are loaded regardless of them being blocked with your plugin. Just wondering what your recommendation would be for this?

    Examples of urls

    example.com/store (Plugins are disabled – Working Properly)

    example.com/store?gclid=4534512423 (Plugins are not disabled – Not Working Properly)

    • This topic was modified 7 months, 1 week ago by Tim Dueck.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author enomoto celtislab

    (@enomoto-celtislab)

    What is the page type of example.com/store page?
    If this is a single page, I think the per-page filter will work, but if it’s an archive page or something like that, you might be able to set up a ‘URL Filter for Expert’.

    Add the keyword store to the URL filter and filter it.

    It is a custom post type taxonomy page. So if I set the url filter to store will it allow your plugin to run on that page? The problem is that currently I am disabling plugins to be only on specific pages, but on these taxonomies it ignores your plugin and doesn’t listen to the page rules that I’ve set.

    Plugin Author enomoto celtislab

    (@enomoto-celtislab)

    Currently the URL filter does not reflect the filter for a specific page if there is a keyword match within the request URL.

    URL filter ‘store’ makes it difficult.

    If it’s a taxonomy page with a custom post type, do you see a custom post type in the page type filter?

    If the custom post type is displayed, I think you can filter it if you set it there, but depending on the target plugin, there may be a case where you can’t process it well.

    So the URL filter is doing the exact opposite of what I need when I use the URL filter it allows the plugins to run on the taxonomy pages. I am wanting to disable certain plugins on these pages since they load way more than is necessary.

    Also like I mentioned your plugin is working correctly how I want, I am able to set up your plugin nicely on my taxonomy pages. However, as soon as a question mark indicating a query string is added to the end of the URL your plugin no longer works as it’s supposed to.

    example.com/store – This works how it should, all bloat from extra plugins is disabled

    example.com/store?123 – Your plugin does not run, meaning that all this extra bloat from certain plugins is enabled on these pages.

    Another plugin that his a similar feature is the redirection plugin, here it explains how this feature works under the Query Parameters heading.
    https://redirection.me/support/matching-a-url/

    Let me know if that makes sense?

    Plugin Author enomoto celtislab

    (@enomoto-celtislab)

    The problem here is that example.com/store will be recognized as an archive and the ‘ If you use example.com/store?123 , it is recognized as a single page. I guess that’s what I’m saying.

    example.com/store?123 must also be recognized as an archive It’s not, but somehow it’s not.

    However, this behavior is dependent on the plugin or theme.

    For example, if you’re using WooCommerce, the ‘store’ page may or may not be recognized as an archive, depending on whether or not the theme supports WooCommerce.

    Programmatically, it is judged by WP functions such as is_archive(), is_page(), is_single(), etc., but it may not be able to be judged correctly depending on the plugins or themes you are using.

    The way to deal with the problem is to switch to a theme or plugin that doesn’t cause any problems.
    Or you can use the URL filter instead of using functions like is_archive(), is_page(), etc.

    However, the current URL filter doesn’t seem to have enough functionality…

    As for the URL filter, we’re planning to develop it as an add-on with more features, so it should be able to handle problems like this one in the future.

    @enomoto-celtislab Ok that makes sense, thank you for the in-depth explanation and bearing with me. Once again, love this plugin! Thank you for taking the time to help me.

    Have a great day!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Query String Disable Plugins’ is closed to new replies.