Support » Plugin: Query Monitor » Query Monitor crashes my site

  • It used to work beautifully on the previous hosting plan.
    I made an upgrade to a more robust hosting plan but now when I activate the plugin the main page does not show right and the query monitor menu does not appear.

    For sure I’m missing something….

    Please help as I really like the plug-in a lot.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Sorry to hear this.

    * Does the “Query Monitor” item in the admin toolbar show at all or is it completely missing?
    * Are there any errors in your PHP error log?
    * Are there any JavaScript errors in your browser console?
    * Can you try deactivating your other plugins one by one to see if there’s a conflict?

    Dear John:

    It is an honor to have you reply to my ticket.

    * Does the “Query Monitor” item in the admin toolbar show at all or is it completely missing?
    It shows but it does not display anything.
    ————————————————————–
    * Are there any errors in your PHP error log?
    No
    ————————————————————–
    * Are there any JavaScript errors in your browser console?
    Image here:
    https://imgur.com/a/FJvEOIh

    I suspect it has to do with the ERR_HTTP2_PROTOCOL_ERROR error

    * Can you try deactivating your other plugins one by one to see if there’s a conflict?
    I rather not, it is very time-consuming.
    Let’s see if the image sheds some light on the solution.

    Thank you John

    Any thoughts John?

    eibihp

    (@eibihp)

    HELP!

    eibihp

    (@eibihp)

    Cab anybody help me!?

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Have you had time to try deactivating your other plugins one by one? There’s not really anything I can help with otherwise. Those JavaScript errors aren’t coming from Query Monitor.

    /wp-admin/plugins.php?plugin_status=all&paged=1&s#qm-overview:1 Failed to load resource: net::ERR_HTTP2_PROTOCOL_ERROR
    DevTools failed to load SourceMap: Could not load content for https://img1.wsimg.com/tcc/tcc_l.combined.1.0.6.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
    DevTools failed to load SourceMap: Could not load content for https://kanabos.mx/wp-content/plugins/free-shipping-notification-woocommerce-pro/admin/js/jsrender.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
    wp-auth-check.min.js?ver=5.5.3:2 Uncaught TypeError: Cannot read property ‘hasClass’ of undefined
    at HTMLDocument.<anonymous> (wp-auth-check.min.js?ver=5.5.3:2)
    at HTMLDocument.dispatch (jquery.js?ver=1.12.4-wp:3)
    at HTMLDocument.r.handle (jquery.js?ver=1.12.4-wp:3)
    at Object.trigger (jquery.js?ver=1.12.4-wp:3)
    at HTMLDocument.<anonymous> (jquery.js?ver=1.12.4-wp:3)
    at Function.each (jquery.js?ver=1.12.4-wp:2)
    at n.fn.init.each (jquery.js?ver=1.12.4-wp:2)
    at n.fn.init.trigger (jquery.js?ver=1.12.4-wp:3)
    at Object.<anonymous> (heartbeat.min.js?ver=5.5.3:2)
    at i (jquery.js?ver=1.12.4-wp:2)

    I enabled the plugin and then received the following error…..

    Failed to load resource: net::ERR_HTTP2_PROTOCOL_ERROR
    wp-auth-check.min.js?ver=5.5.3:2 Uncaught TypeError: Cannot read property ‘hasClass’ of undefined
    at HTMLDocument.<anonymous> (wp-auth-check.min.js?ver=5.5.3:2)
    at HTMLDocument.dispatch (jquery.js?ver=1.12.4-wp:3)
    at HTMLDocument.r.handle (jquery.js?ver=1.12.4-wp:3)
    at Object.trigger (jquery.js?ver=1.12.4-wp:3)
    at HTMLDocument.<anonymous> (jquery.js?ver=1.12.4-wp:3)
    at Function.each (jquery.js?ver=1.12.4-wp:2)
    at n.fn.init.each (jquery.js?ver=1.12.4-wp:2)
    at n.fn.init.trigger (jquery.js?ver=1.12.4-wp:3)
    at Object.<anonymous> (heartbeat.min.js?ver=5.5.3:2)
    at i (jquery.js?ver=1.12.4-wp:2)

    With the plugin disabled I do not get these errors!
    Please note

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.