WordPress.org

Support

Support » Plugins and Hacks » qTranslate » qTranslsate broken with WP 3.1.3

qTranslsate broken with WP 3.1.3

  • The plug-in is not working anymore with WP 3.1.3 even if by changing 3.1.2 to 3.1.3 in the main .php file.

    I also suspect qTranslate to broke the default wp editor in 3.1.2.

    Will you plan to update this plug-in or make 3.0 plug-in version available?

    Nice job anyway, your addon rock!

    Cheers

Viewing 4 replies - 1 through 4 (of 4 total)
  • qTranslate is not properly broken, simply the author has written into the plugin’s code a PHP define with the current WordPress version.

    I have found a little workaround, but You should use it only if You think that is absolutely needed, otherwise I suggest You to wait for the upcoming new release of the plugin:

    – First of all remember to backup!
    – open the file qtranslate.php in Your plugin’s directory (usually /wp-content/plugins/qtranslate/qtranslate.php)
    – look for define('QT_SUPPORTED_WP_VERSION', '3.1.2'); around line 84
    – change this to define('QT_SUPPORTED_WP_VERSION', '3.1.3'); (or the current version number of WP that You are using) and save the file.

    It should work. But remember that there is no warranty! The workaround is used at Your risk and it might cause problems and/or data loss.

    Waiting for the new plugin release is strongly raccomanded.

    I hope it can help!

    Hye fabri and thx for the reply but did you read my post at the first line:

    The plug-in is not working anymore with WP 3.1.3 even if by changing 3.1.2 to 3.1.3 in the main .php file.

    This is the workaround you suggest…

    Cheers

    It is not breaking the editor. Instead I get this message popping up: “The qTranslate Editor has disabled itself because it hasn’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version.”

    I just click on “Clicking here” and it obeys me!

    Waiting for the plugin author to find time to do the update.

    S.K

    The plugin has been updated. No out-of-date error now. Tested with 3.1.3 and below.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘qTranslsate broken with WP 3.1.3’ is closed to new replies.
Skip to toolbar