Support » Plugin: qTranslate X » qTranslate's compatibility with other plug-ins

  • Resolved rachel75

    (@rachel75)


    Hello,
    I love qTranslate and want to continue to use it, but I’ve had some compatibility problems with other plug-ins.
    First, WordPress SEO by Yoast. I found one post in this support forum about it, but didn’t understand it; I’m completely digitally ignorant! That’s why I like that SEO plug-in: it guides me through the steps to make sure my post is set up well for SEO. Now, with qTranslate installed, it inserts some code that throws off its evaluation. So if my keyword is “Marina del Rey” then it thinks it’s [:en]marina del rey[:] and tells me my SEO is poor because that phrase with the code isn’t anywhere in my text. I don’t know if it actually IS poor, but that’s what it tells me.
    A similar thing is happening with the plug-in Revive Old Post. Each tweet it sends out for me adds [:en] and [:] around the title of the post.
    Could you help me fix this? And could you use as little jargon as possible in doing it?

    https://wordpress.org/plugins/qtranslate-x/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Gunu

    (@grafcom)

    @rachel75

    first, you also have this installed? WordPress SEO & qTranslate-X

    Yes, I have it and activated it, but it makes no difference.

    Plugin Author Gunu

    (@grafcom)

    @rachel75

    I did a test with SEO to reproduce, I get:
    The keyword / phrase [:en]language[:nl]taal[:de]sprache[:] does not appear in the page title.

    Then I view the website page (right click, view page source)

    <!-- This site is optimized with the Yoast WordPress SEO plugin v2.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
    <meta name="robots" content="noindex,follow"/>
    <meta name="description" content="this is the meta description EN"/>
    <link rel="canonical" href="http://www.mysite.com/presentatie/en/language-test-en/" />
    <meta property="og:locale" content="en_US" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="language test EN" />
    <meta property="og:description" content="this is the meta description EN" />
    <meta property="og:url" content="http://www.mysite.com/presentatie/en/language-test-en/" />
    <meta property="og:site_name" content="Test Site EN" />
    <meta property="article:section" content="Presentatie EN" />
    <meta property="article:published_time" content="2015-04-25T08:37:46+00:00" />
    <meta property="article:modified_time" content="2015-06-14T09:46:15+00:00" />
    <meta property="og:updated_time" content="2015-06-14T09:46:15+00:00" />
    <!-- / Yoast WordPress SEO plugin. -->

    The title is displayed correctly in different languages/

    So should I then assume that the SEO is good, even if the plug-in is giving me the message that it’s not?

    What I mean is, there’s a series of points it checks (having the key word in the title is one of them, so is having the key word in the text, etc.), and then it gives a total, indicated by a red, yellow or green icon. I go through the list of points and know I’ve done everything for it to rate good (green icon), but it shows me yellow because it thinks I don’t have the key word in the text, etc.

    That doesn’t bother me, except I want to know that GOOGLE will read it correctly. So will it?

    (In other words, I have no idea what all that is that you quoted above!)

    And is there a way to fix this in Revive Old Posts? Or can you recommend a different plug-in that won’t add the code?

    I appreciate the help, by the way! Thanks!

    Plugin Author Gunu

    (@grafcom)

    @rachel75

    what I mean is that the page titles are displayed correctly on the website pages so search engines read this correct.

    And is there a way to fix this in Revive Old Posts?

    To do that in Jip en Janneke taal 🙂 is not that simple.

    I could install the plugin on my test site, but then you must make the settings, I give you then access to my test site ok?

    Okay, sure. I’ll set it just as I’ve set mine.

    Plugin Author Gunu

    (@grafcom)

    @rachel75,

    send me a mail so I can give you access.

    But first try this:

    Use the <!--:en--><!--:--> (in raw mode) instead of [:en][:]

    See if it works for you.

    Plugin Author Gunu

    (@grafcom)

    @rachel75

    this has now been resolved?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘qTranslate's compatibility with other plug-ins’ is closed to new replies.