Support » Plugins » [qTranslate2] does not work with 2.7.1 – permissions issue

  • Resolved dczepiel

    (@dczepiel)


    Hello,

    After upgrading WordPress to 2.7.1 I could not access the admin panel. It showed me a message “You do not have sufficient permissions to access this page”. I deactivated all the plugins (by chaning the plugins directory name) and then was able to log into admin panel. Then I tried to reactivate all the plugins again, one by one, and it seems like qTranslate 2 is the only plugin that causes problems. Whenever I try to activate it, I get kicked out of the admin panel with the You do not have sufficient permissions to access this page” message.

    I am using qTranslate version 2.3.2
    Right now it’s either Qtranslate or the Admin Panel which makes blogging a real nightmare.

    Any clues what might have happened and how to fix it?
    http://dczepiel.pl

Viewing 3 replies - 1 through 3 (of 3 total)
  • noone experiences the same problem?

    Problem solved.

    I am running polish (default) and english.
    What needs to be done is the wp_default_secert_key value must be the same in 3 files.

    wp-content/languages file PL_pl.php should contain:
    $wp_default_secret_key = 'whatever';

    wp-config.php should contain:

    define('AUTH_KEY', 'whatever'); // Change this to a unique phrase.
    define('SECURE_AUTH_KEY', 'whatever'); // Change this to a unique phrase.
    define('LOGGED_IN_KEY', 'whatever'); // Change this to a unique phrase.

    AND wp-settings.php should have there somewhere:
    $wp_default_secret_key = 'whatever';

    Hope that helps.

    I can’t find any FR_fr.php or EN_en.php files at all, where are they please?

    I suddenly wasn’t able to log on my account… Maybe did I enter a wrong password but now my pages in English (the default language) can’t be accessed at all, nor the admin panel.

    I have no clue what happened, can anyone help?

    Thanks,
    Ceriko.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[qTranslate2] does not work with 2.7.1 – permissions issue’ is closed to new replies.