WordPress.org

Support

Support » Plugins and Hacks » [Resolved] qTranslate broken after update WP to 3.5 version

[Resolved] qTranslate broken after update WP to 3.5 version

  • I have updated my WordPress using qTranslate plugin to 3.5 version Today, and qTranslate works incorrect:
    “The qTranslate Editor has disabled itself because it hasn’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version”

    http://wordpress.org/extend/plugins/qtranslate/

Viewing 15 replies - 1 through 15 (of 42 total)
  • Have you tried reading this or this or maybe even this?

    If you did, you would have seen that they link to an article where I’ve explained how you can work-around this issue. If you had tried my solution and it doesn’t work – then you should post in a different thread and not start a new one.

    Please if this fixes the issue for you, mark this topic as fixed.

    Thank you, nikolov.tmw. I was inattentive.
    It helped me: http://www.qianqin.de/qtranslate/forum/viewtopic.php?f=3&t=3831

    Glad it worked 🙂

    Just to summarize the solution for the problem:

    Use this code for qtranslate_javascript.php: Pastebin

    User this in qtranslate.php:
    change define('QT_SUPPORTED_WP_VERSION', '3.4.2');
    to define('QT_SUPPORTED_WP_VERSION', '3.5');

    I get this error after fixing.

    Warning: Cannot modify header information – headers already sent by…

    EDIT: With the Code “RAW Paste Data” at the botton of the page it works!

    Thanks TIIUNDER. I was albe to use your fix and my site is working well (again). I might add that I used the beta version 2.5.32 and added the code above (pastebin). You can find it here: http://www.qianqin.de/qtranslate/download/

    After doing the change in QT_SUPPORTED_WP_VERSION and qtranslate_javascript.php I have another problem: if I update a page with the visual editor the contents are not saved; if I do it with the Text editor, it’s ok.

    Anyone more having this question? anyone has found the solution?

    I see the solution: edit in Visual editor and don’t save from there, but change to the Text editor and save. (Not very functional, but…)

    Apart from this, I see the height of the editor is getting small every time.

    I have the some problem. Thank you, danitxu, for fast solution!
    Any idea how fix it?

    Hi everyone,
    First of all thanks for the change of qtranslate!

    However I experience the same thing with the editor box; it appears very small.
    On a different forum I found that if I change the adjusted part in qtranslate_javascript.php (line 26) from 300 to higher, it would change the size. But that doesn’t work?

    Any ideas?

    Hi everyone,

    The problem with the editor not saving the post contents seems to fix when you load the page with the Text editor selected(you can add this code – add_filter( 'wp_default_editor', create_function('', 'return "html";') ); to your functions.php) and then switch to the visual editor, everything seems to work. Note that with this hack after saving on the first page load you will see the visual editor again, but if you refresh the page you will see the Text editor by default again.

    I know that this is not the best solution, but the thing is that qTranslate uses a lot of hacks revolving around the tinyMCE editor, that it’s pretty difficult for me to find what exactly breaks the fix.

    About the size of the editor – I’m not sure why my hack doesn’t work everywhere 🙁

    If I change the code of qtranslate_javascript.php then I receive this message:

    Fatal error: Call to undefined function qtrans_initjs() in D:\www\www314\wp\wp-content\plugins\qtranslate\qtranslate_core.php on line 59

    In qtranslate_core.php on line 59 I found:
    qtrans_initJS();

    Could you tell me what’s wrong?

    Well it seems that you’re missing the definition of the qtrans_initJS function. This should be in qtranslate_javascript.php and you should have something like function qtrans_initJS() {... .

    I don’t….
    What and where do I have to put it in?

    Just copy the content from here and paste it to the qtranslate_javascript.php file.

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘[Resolved] qTranslate broken after update WP to 3.5 version’ is closed to new replies.