WordPress.org

Support

Support » Plugins and Hacks » Feature A Page Widget » [Resolved] QTranslate?

[Resolved] QTranslate?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mark Root-Wiley

    @mrwweb

    Hi @oolongtea

    Thank you for reporting this issue. I have confirmed the problem and listed the plugin as officially incompatible (for now) on the plugin’s page for other peoples’ knowledge.

    I’m unfamiliar with what qTranslate requires for compatibility, so this may take some time to resolve, but I do hope to get the plugins to play nicely sooner rather than later.

    Many thanks! 🙂 I shall, somewhat impatiently, await that update.
    I´m sorry I can´t give you any tips on how qTranslate works on the inside. I just happily and unknowingly use it. It´s pretty straight forward but if you have any questions about how to use it I´ll do my very best help you out.

    Hi,

    First of all: Very nice Plugin! In fact, it is so nice (and useful) I dug into the code to find a solution for the qTranslate “problem”. And I possibly found one 🙂

    The problem seems to be how the strings get escaped. qTranslate relies on XML-Tags to identify different languages (see first post from oolongtea).

    The two functions esc_attr() and esc_html() are escaping the needed tags for qTranslate to identify the different languages.

    But there are translation-ready alternatives to these functions:
    esc_attr__() and esc_html__().

    I’m not sure if there are implications of using these functions, but they work 🙂 I haven’t witnessed any downsides.

    Hope this helps.

    Plugin Author Mark Root-Wiley

    @mrwweb

    @wecreate,

    Thank you very much for looking into a fix. What you found makes sense (though I can’t say I had thought of it) and sounds like it would be a safe fix to implement.

    I’ll try to look into it in the next week and get a release out if it seems to work.

    Plugin Author Mark Root-Wiley

    @mrwweb

    @oolongtea and @wecreate, I believe that I’ve got the widget working with qTranslate now.

    I’m still not super familiar with the plugin, so please let me know if I’ve overlooked anything. If new issues arise, please open up a new thread as I’m marking this one resolved.

    @mrwweb, @wecreate.

    Thank you 🙂 Great! Appreciate it a lot! Many thanks! Sunshine to you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] QTranslate?’ is closed to new replies.
Skip to toolbar