Support » Plugin: AddQuicktag » AddQT v2.2 causes HTML Editor buttons to disappear

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Frank Bueltge

    (@bueltge)

    I have also tested, my quicktags was view in html (text) and visuell mode, always and in dependence of settings.

    Thanks for the reply Frank.

    I checked things again:
    AddQT is working fine in Pages and Posts.

    I have two Custom Post Types (created with the Types plugin) – in the case of the HTML editor for these CPT’s, the basic buttons appear, but the AddQT buttons do not appear.

    Sorry for misstating the situation. Should the plugin add quicktags when adding content to CPTs? (If ‘yes’, then perhaps there is a conflict when I use Types plugin).

    Plugin Author Frank Bueltge

    (@bueltge)

    Is my understanding right?
    You use it on 2 CPTs and you see the AddQts only on visuell editor?
    not on text-Editor.
    Do you have active the checkboxes on the settings for this custom post types?

    No, not quite what I have.

    This is what I am seeing:

    – Visual editor – No AddQT buttons on any editor page (not Pages, nor Posts) (I have the buttons checked for Visual editor in QT setup page)

    – HTML editor, Posts and Pages – AddQT buttons appear

    – HTML editor, Custom Post Types – No AddQT buttons

    Also: I tested using Custom Post Types created via functions.php, just to be sure that the problem was not Types plugin. I don’t get AddQT buttons showing up for either form of CPT.

    In case my computer setup is of importance:
    Windows Vista, 32 bit, Firefox (latest), WordPress (3.5.1)

    I hope that this info helps.

    Plugin Author Frank Bueltge

    (@bueltge)

    – Visual editor – No AddQT buttons on any editor page (not Pages, nor Posts) (I have the buttons checked for Visual editor in QT setup page)

    This is the default, no CPT – hmm.
    Can you check inside the console of Webinspector in Chrome or Firebug in FF, there you have a js problem. You see it on a red icon in Chrome or see on the Console of Firebug for Errors.

    I have tested now in FF, it works on visual and html mode on posts and pages.
    see: https://www.diigo.com/item/image/1j30r/gn4j

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘AddQT v2.2 causes HTML Editor buttons to disappear’ is closed to new replies.