Support » Plugin: ActivityPub » Qs after latest

  • Guten Tag Matthias,
    Just updated to latest version (Version 0.11.2).
    Frankly hadn’t checked options for a while, but have 2 remarks:

    1 – seems I lost all my followers (about 20), or they don’t appear anymore in Users/Followers. (same on 2 blogs @ separate URL amf. & www.)
    Unfortunately, mastodon.host where my account is, has been down for 15+ days and I can’t check what happens when I publish…
    To be clear, I don’t know if this is due to the latest release or not.

    2 – The custom Post-Content option is cool. But what happens with images (e.g. featured image). There’s no template placeholder. Is it managed automatically via %content% ?

    Thx
    Sincerely
    DJM

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Matthias Pfefferle

    (@pfefferle)

    Regarding 1: This is weird, I will try to investigate here. But I am not aware of any changes that caused this issue.

    Regarding 2: The featured images is added as an attachment for now, but not inline. Mastodon seems to not show inline images (as html) at all, at least I am not aware of it. But I can add that as placeholder for a future release. thanks for the idea!

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    I have no exact idea why you lost your followers, but it might be because I interpreted an “undo” action as an unfollow for about one version. This is fixed in the latest version.

    I work on a CRUD feature for followers, so that you will be able to (re-)add, delete or update your followers.

    Sorry for the problems 🙁

    Thread Starter didierjm

    (@didierjm)

    Thx Matthias.
    I checked on the 3 sites I enabled with ActivityPub and where I had followers (at least my own mastodon account following) and all 3 have no more followers appearing…
    Can’t check anymore as mastodon.host has been impossible to access for at least 3 weeks, so can’t reach my account…

    What’s strange, BTW, is I followed from inside Mastodon, not from the WP blog.

    Sincerely
    DJM

    Thread Starter didierjm

    (@didierjm)

    Hi again,
    Might have found a reason why (not sure, o’course) or something totally unrelated…

    Checked WP Site Health on 2 of my blogs and have a new error/problem to improve:

    “1 critical issue
    Profile URL is not accessible [ActivityPub]
    Authorization Headers are being blocked by your hosting provider. This will cause IndieAuth to fail.”

    Tested in both FF (latest) and Chrome: same msg
    Did my hosting provider really enable some filter (what level: PHP, SSL?) or does a plugin scramble the connection?

    But if indeed I can’t have access to my profile, I might not get my followers list…

    Strange again…

    PS: on 1 site I installed NodeInfo yesterday, not on second.
    PS2: checked the 3rd blog where AP is enabled, same provider, but not same server. Error appears too.
    PS3: all the blogs are whitelisted for PrivacyBadger, Cookie AutoDelete and uBlock Origin.
    Sincerely
    DJM

    Blogs (https all):
    http://www.didiermary.fr
    amf.didiermary.fr
    http://www.steveshehan.com

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Yes, it seems that your blog does not return the JSON it should be:

    
    curl "https://www.didiermary.fr/author/cybeardjm/" \
         -H 'Accept: application/activity+json'
    

    and I have to change the error text, it is a copy&paste issue 🙁

    Thread Starter didierjm

    (@didierjm)

    Hi Matthias,
    When did you test?
    Yesterday, I restarted my hosting instance, deactivated and reactivated the ActivityPub plugin.

    Error disappeared from the critical issues in WP Site Health (status = good)

    Then I created a new profile on mstdn.social, followed my 2 blogs (and you too).
    Then posted from amf.didiermary.fr and it worked: post appeared in TL:
    https://mstdn.social/web/statuses/105543409438636515

    But my followers list is still empty…

    What should I check for the JSON problem?

    Sincerely
    DJM

    Thread Starter didierjm

    (@didierjm)

    BTW, error disappeared on both blogs (www & amf).
    Just disabled all other plugins relating to Fediverse, microformats, nodeinfo, semantic, syndication… on both sites.
    ActivityPub is the only plugin related to Fediverse that’s on.
    Disabled minified files.

    How should I test the JSON part? Don’t have a console to test with cURL
    DJM

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.